beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Song (JIRA)" <beehive-...@incubator.apache.org>
Subject [jira] Created: (BEEHIVE-828) @VersionRequired not supported on @ControlInterface
Date Fri, 17 Jun 2005 23:23:18 GMT
@VersionRequired not supported on @ControlInterface
---------------------------------------------------

         Key: BEEHIVE-828
         URL: http://issues.apache.org/jira/browse/BEEHIVE-828
     Project: Beehive
        Type: Bug
    Versions: v1m1    
    Reporter: James Song
 Assigned to: Eddie O'Neil 
     Fix For: TBD


This is a follow-up of JIRA230, and JIRA-118 is related to this.
Currently, @VersionRequired on ControlInterface causes a compile error. But, according to
http://incubator.apache.org/beehive/controls/controlsProgramming.html#Defining+an+Extended+Interface+for+a+Control+Type
, an entended control interface could be declared with @ControlInterface.

Not supporting @VersionRequired on ControlInterface mean version control is incomplete.


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message