beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ias" <iasan...@hotmail.com>
Subject RE: drt - Playback FAILED for test( FormatTags )
Date Sat, 18 Sep 2004 18:26:24 GMT
Now "ant drt" in NetUI works fine without any test failure under Korean
locale.

Thanks very much,

Ias 

> -----Original Message-----
> From: Eddie O'Neil [mailto:ekoneil@bea.com] 
> Sent: Saturday, September 18, 2004 3:53 PM
> To: Beehive Developers
> Subject: Re: drt - Playback FAILED for test( FormatTags )
> 
> All--
> 
>   I've fixed the FormatTags test so that it should run in 
> non-US locales. 
> 
>   There are two BVT failures that will occur with non-US locales:
> 
> CtFormatDateNullBinding
> DateConverter
> 
> These will need to be looked at, but the DRTs should pass for 
> you now.  
> If they don't, let me know. 
> 
>   The tests were run in an NL/BE locale.
> 
> Eddie
> 
> 
> 
> 
> 
> Ram M Mishra wrote:
> 
> >Sorry for last message. It has been sent by mistake.
> >
> >Regards,
> >Ram Mohan
> >
> >
> >
> >
> >
> >Ram M Mishra/India/IBM@IBMIN
> >09/17/2004 03:45 PM
> >Please respond to "Beehive Developers"
> > 
> >        To:     "Beehive Developers" 
> <beehive-dev@incubator.apache.org>
> >        cc: 
> >        Subject:        RE: drt - Playback FAILED for test( 
> FormatTags )
> >
> > 
> >
> >same to you.
> >
> >
> >
> >
> >
> >"Ias" <iasandcb@hotmail.com>
> >09/17/2004 02:51 PM
> >Please respond to "Beehive Developers"
> > 
> >        To:     "'Beehive Developers'" 
> <beehive-dev@incubator.apache.org>
> >        cc: 
> >        Subject:        RE: drt - Playback FAILED for test( 
> FormatTags )
> >
> > 
> >
> >  
> >
> >>Rotan--
> >>
> >>  The failure of the FormatTags on a non-US locale should't 
> keep you 
> >>from developing with NetUI in Beehive.
> >>    
> >>
> >
> >It shouldn't, but seeing failure from "ant drt" on NetUI 
> everytime due 
> >to locale problem doesn't seem pleasant, I think. Is there 
> any feasible 
> >way to figure this situation out? For example, if it's 
> really hard to 
> >go straight, disabling those test cases in case of non-US locale may 
> >help (either automatically or manually).
> >
> >Thanks,
> >
> >Ias
> >
> >  
> >
> >>  Beehive itself isn't failing in your locale -- just a specific 
> >>instance of a test using a <netui:formatDate> tag.
> >>This is because the test itself was recorded in a US locale 
> and that 
> >>Locale just isn't being set / picked-up correctly for the given JSP 
> >>page.
> >>
> >>  The ModuleConfigLocator test you mentioned was another 
> >>Locale-related failure we've seen in the last few weeks -- the diff 
> >>showed that the "lang" attribute on the <html> tag was showing up 
> >>localized rather than "en".
> >>
> >>  Hope that helps.  Have fun!
> >>
> >>Eddie
> >>
> >>
> >>
> >>
> >>               -----Original Message----- 
> >>               From: Rotan Hanrahan
> >>    
> >>
> >[mailto:Rotan.Hanrahan@MobileAware.com]
> >  
> >
> >>               Sent: Sun 8/15/2004 5:50 PM 
> >>               To: beehive-dev@incubator.apache.org 
> >>               Cc: 
> >>               Subject: drt - Playback FAILED for test( FormatTags )
> >>
> >>
> >>
> >>               [ Developing with NetBeans4 (a beta, but 
> fairly ok for 
> >>Java 1.5), on WinXP and SuSE 9.1 ]
> >>
> >>               I can build: clean deploy drt
> >>               but the drt build has one little error:
> >>
> >>                    Playback FAILED for test( FormatTags )
> >>
> >>               which, as you know, is likely caused by 
> locale problems.
> >>
> >>               I'm building on a machine configured for my locale 
> >>(English language, Irish environment) and I prefer not to make any 
> >>global changes because that would break other things I'm working on.
> >>
> >>               I've isolated NetBeans4 into its own execution 
> >>environment so that (for example) its JAVA_HOME is 
> JDK1.5.0, and not 
> >>the 1.4.2 I use normally. Having to further isolate the build 
> >>environment into a temporary US locale defeats the purpose of the 
> >>test, so I'll leave it alone. Should I have any further reason to 
> >>worry if I continue to experiment on Beehive while in a locale it 
> >>fails on?
> >>
> >>               And did ModuleConfigLocator have a problem 
> with locale? 
> >>Or was it just a coincidence that it previously failed at the same 
> >>time as FormatTags (which *did* have a problem with locale)?
> >>
> >>               I've attaced the ant build output to this message if 
> >>anyone is interested (though I'm unsure about how the Apache mailer 
> >>handles attachments).
> >>
> >>               ---Rotan
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>    
> >>
> >
> >
> >
> >  
> >
> 

Mime
View raw message