beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Song" <js...@bea.com>
Subject RE: Looking for source directories ( kinda long )
Date Thu, 09 Sep 2004 17:41:59 GMT
Eddie:
Thanks for the tip. Controls drt is switched to "ensure.deployed" target i/o "deploy" target,
this should make it more robust.

-James 

-----Original Message-----
From: Eddie O'Neil 
Sent: Wednesday, September 08, 2004 11:33 AM
To: Beehive Developers
Subject: Re: Looking for source directories ( kinda long )


James--

  You might take a look at the "ensure.deployed" call that NetUI uses 
for our netui/test/webapps/drt/build.xml to ensure that the webapp is 
either deployed or redeployed depending on the previous state of Tomcat 
and the webapp.

  That can help keep these kinds of errors from happening as failure 
conditions that cause the webapp to not undeploy may be common.  You 
could also consider having a "scrub" target that deletes all of the 
controlsWeb resources deployed into Tomcat rather than having to 
reinstall Tomcat after a failure.

  Hope that helps.

Eddie

James Song wrote:

>Furthermore:
>
>controls drt undeploys controlsWeb from the Tomcat instance after running controls drt.
But, this did not happen in your frist try.
>Undeploying the existing controlsWeb (or reinstall your Tomcat) should solve this problem.
>
>-James
>
>-----Original Message-----
>From: James Song 
>Sent: Wednesday, September 08, 2004 11:17 AM
>To: Beehive Developers
>Subject: RE: Looking for source directories ( kinda long )
>
>
>The last error:
>
>  
>
>>deploy:
>>deploy:
>>    [echo] deploy webapp from file://C:\eclipse\workspace\Beehive\controls\test\webapps/controlsWeb
with context path controlsWeb
>>[tomcatdeploy] FAIL - Application already exists at path /controlsWeb
>>------------------------------------
>>
>>Finally, stuck again.  :(
>>Hm... "/controlsWeb" already exists.
>>    
>>
>
>
>controls drt tries to deploy controlsWeb into  your Tomcat instance. controlsWeb might
had been deployed in your first try.
>If you remove/reinstall your Tomcat, this should be solved.
>
>-James
>
>-----Original Message-----
>From: Eddie O'Neil 
>Sent: Wednesday, September 08, 2004 11:04 AM
>To: Beehive Developers
>Subject: Re: Looking for source directories ( kinda long )
>
>
>Wolfgang--
>
>  Yes, the controls DRT has a dependency on the presence of the NetUI 
>runtime so that it can test controls inside of a webapp.
>
>  That being said, it looks like the controls DRT infrastructure for 
>ensuring that a webapp is correctly deployed to Tomcat may not work in 
>all cases; James or Zach, can you offer any insight here?
>
>  Thanks!
>
>Eddie
>
>
>
>wolfgang127us@yahoo.co.jp wrote:
>
>  
>
>>Hi all,
>>
>>I've received the answer about netui.drt from Rich.
>>All tests passed. 
>>
>>wsm.drt & netui.drt are okay so far, but I still cannot tell okay or not for controls.drt
>>since Ant always stops before reaching the test part. 
>>
>>Here is what I've done and got on console.
>>
>>I tried controls.drt ant task.
>>
>> A couple of last lines on the eclipse console, 
>>------------------------------------
>>deploy.netui.runtime:
>>deploy.netui.runtime:
>>   [mkdir] Created dir: C:\eclipse\workspace\Beehive\controls\test\webapps\controlsWeb\resources\javascript
>>deploy-struts:
>>    [echo] Deploy Struts to webapp rooted at: C:\eclipse\workspace\Beehive\controls\test\webapps\controlsWeb
>>    [exec] Using CATALINA_BASE:   C:\eclipse\workspace\Beehive\installed\jakarta-tomcat-5.0.25
>>    [exec] Using CATALINA_HOME:   C:\eclipse\workspace\Beehive\installed\jakarta-tomcat-5.0.25
>>    [exec] Using CATALINA_TMPDIR: C:\eclipse\workspace\Beehive\installed\jakarta-tomcat-5.0.25\temp
>>    [exec] Using JAVA_HOME:       C:\Program Files\Java\jdk1.5.0
>>------------------------------------
>>
>>A couple of last lines on the TOMCAT console (DOS),
>>------------------------------------
>>Sep 9, 2004 1:39:28 AM org.apache.jk.common.ChannelSocket init
>>INFO: JK2: ajp13 listening on /0.0.0.0:8009
>>Sep 9, 2004 1:39:28 AM org.apache.jk.server.JkMain start
>>INFO: Jk running ID=0 time=16/94  config=C:\eclipse\workspace\Beehive\installed\
>>jakarta-tomcat-5.0.25\conf\jk2.properties
>>Sep 9, 2004 1:39:28 AM org.apache.catalina.startup.Catalina start
>>INFO: Server startup in 44312 ms
>>------------------------------------
>>
>>It was seemed stuck there.
>>Even though I waited over 20 mins, no further processing was performed.
>>So I had forcelly stopped Tomcat, then eclipse displayed the following lines.
>>------------------------------------
>>    [exec] Result: 1
>>BUILD FAILED: C:\eclipse\workspace\Beehive\build.xml:57: The following error occurred
while executing this line:
>>C:\eclipse\workspace\Beehive\controls\build.xml:259: The following error occurred
while executing this line:
>>C:\eclipse\workspace\Beehive\controls\test\build.xml:218: The following error occurred
while executing this line:
>>C:\eclipse\workspace\Beehive\controls\test\build.xml:233: The following error occurred
while executing this line:
>>C:\eclipse\workspace\Beehive\controls\test\webapps\build.xml:60: The following error
occurred while executing this line:
>>C:\eclipse\workspace\Beehive\test\ant\deployNetui.xml:14: The following error occurred
while executing this line:
>>C:\eclipse\workspace\Beehive\netui\build.xml:79: The following error occurred while
executing this line:
>>C:\eclipse\workspace\Beehive\netui\ant\build.xml:79: The following error occurred
while executing this line:
>>C:\eclipse\workspace\Beehive\netui\ant\webappTemplate.xml:199: The following error
occurred while executing this line:
>>C:\eclipse\workspace\Beehive\netui\ant\webappTemplate.xml:233: C:\eclipse\workspace\Beehive\netui\build\dist\webapp
not found.
>>Total time: 21 minutes 10 seconds
>>------------------------------------
>>
>>The last line says "C:\eclipse\workspace\Beehive\netui\build\dist\webapp not found."
>>oh...I didn't know that control.drt depends on netui.drt so I did netui.drt and control.drt
again.
>>netui.drt looks okay, but control.drt.
>>Tomcat console was exactly same as the first time. 
>>In contrast, the following lines were displayed on eclipse console.
>>------------------------------------
>>    [echo] ----------------------------------------------
>>    [echo] |     Controls controlsWeb build ending      |
>>    [echo] ----------------------------------------------
>>    [echo] continue the new thread, wait for tomcat to start
>>    [echo] continue the new thread, deploy controlsWeb
>>deploy:
>>deploy:
>>    [echo] deploy webapp from file://C:\eclipse\workspace\Beehive\controls\test\webapps/controlsWeb
with context path controlsWeb
>>[tomcatdeploy] FAIL - Application already exists at path /controlsWeb
>>------------------------------------
>>
>>Finally, stuck again.  :(
>>Hm... "/controlsWeb" already exists.
>>
>>I've tried many combinations of Ant tasks, but couldn't help it.
>>
>>I'm mainly a vi user on linux so actually no impact to me even though Beehive doesn't
work with eclipse.
>>BUT I think many developers out there are willing to use it on eclipse, so please
help me out.
>>
>>Thanks in advance.
>>
>>wolfgang.
>>
>>
>>
>>
>>
>> 
>>
>>    
>>
>
>  
>

Mime
View raw message