beam-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From amir bahmanyari <amirto...@yahoo.com>
Subject Some Compilation errors
Date Tue, 16 Aug 2016 00:52:57 GMT
Hi Colleagues,I am re-building my work from the scratch for a final target delivery.I installed
all the latest and the greatest, and upgraded my POM dependencies, but I get compilation errors
when I build my current code.Following is my new <dependencies> tag and their corresponding
compilation errors I get.Thanks for your feedback.
<dependencies><!-- this works as is. If I change it to 0.2.0-incubating, I get this
error:cannot find symbol[ERROR] symbol:   method named(java.lang.String)[ERROR] location:
class org.apache.beam.sdk.transforms.ParDo--><dependency>
   <groupId>org.apache.beam</groupId>   <artifactId>beam-runners-core-java</artifactId> 
 <version>0.1.0-incubating</version></dependency>



<!-- OK. Compiles with both 0.1.0 & 0.2.0. No issue here -->
<dependency>    <groupId>org.apache.beam</groupId>    <artifactId>beam-sdks-java-io-kafka</artifactId> 
  <version>0.2.0-incubating</version></dependency>


<!-- Compiles with 0.1.0-incubating as is below. It throws the following error at compile
time if changed to 0.2.0-incubating:  
cannot find symbol[ERROR] symbol:   class FlinkPipelineRunner-->
<dependency>    <groupId>org.apache.beam</groupId>    <artifactId>beam-runners-flink_2.10</artifactId> 
  <version>0.1.0-incubating</version></dependency> 
</dependencies>

Mime
View raw message