beam-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Beam JIRA Bot (Jira)" <j...@apache.org>
Subject [jira] [Updated] (BEAM-11816) Remove Java version limit for classic Java runners
Date Mon, 24 May 2021 17:20:00 GMT

     [ https://issues.apache.org/jira/browse/BEAM-11816?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Beam JIRA Bot updated BEAM-11816:
---------------------------------
    Labels: stale-P2  (was: )

> Remove Java version limit for classic Java runners
> --------------------------------------------------
>
>                 Key: BEAM-11816
>                 URL: https://issues.apache.org/jira/browse/BEAM-11816
>             Project: Beam
>          Issue Type: Bug
>          Components: runner-core
>            Reporter: Nir Gazit
>            Priority: P2
>              Labels: stale-P2
>
> It seems there's an artificial restriction in [https://github.com/apache/beam/blob/master/runners/core-construction-java/src/main/java/org/apache/beam/runners/core/construction/Environments.java#L119] that's
preventing Beam from running natively on Java > 11. This restriction should only apply
when trying to use the portable runner, but it's enforced everywhere due to a constant failing
to initialize there.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message