beam-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Morávek <david.mora...@gmail.com>
Subject Re: [DISCUSS] Drop support for Flink 1.7
Date Wed, 19 Feb 2020 11:08:06 GMT
+1 for dropping 1.7, once we have 1.10 support ready

D.

On Tue, Feb 18, 2020 at 7:01 PM <je.ik@seznam.cz> wrote:

> Hi Ismael,
> yes, sure. The proposal would be to have snapshot dependency in the
> feature branch. The snapshot must be changed to release before merge to
> master.
> Jan
>
> Dne 18. 2. 2020 17:55 napsal uživatel Ismaël Mejía <iemejia@gmail.com>:
>
> Just to be sure, you mean Flink 1.11.0-SNAPSHOT ONLY in the next branch
> dependency?
> We should not have any SNAPSHOT dependency from other projects in Beam.
>
> On Tue, Feb 18, 2020 at 5:34 PM <je.ik@seznam.cz> wrote:
>
> Hi=Cr�Jincheng,
> I think there should be a "process" for this. I would propose to:
>  a) create new branch with support for new (snapshot) flink - currently
> that would mean flink 1.11
>  b) as part of this brach drop support for all version up to N - 3
> I think th!t that dropping all versions and adding new version should be
> atomic, otherwise we risk we release beam version with less than three
> supprted flink versions.
> I'd suggest to start with the 1.10 branch support, include the drop of 1.7
> into that branch. Once 1.10 gets merged, we should create 1.11 with
> snapshot dependency to be able to keep up with the release cadence of flink.
> WDYT?
>  Jan
>
> Dne 18. 2. 2020 15:34 napsal uživatel jincheng sun <
> sunjincheng121@gmail.com>:
>
> Hi folks,
>
> Apache Flink 1.10 has completed the release announcement [1]n Then we
> would like to add Flink 1.10 build target and make Flink Runner compatible
> with Flink 1.10 [2]. So, I would suggest that at most three versions of
> Flink runner for Apache Beam community according to the update Policy of
> Apache Flink releases [3] , i.e. I think it's better to maintain the three
> versions of 1.8/1.9/1.10 after add Flink 1.10 build target to Flink runner.
>
> The current existence of Flink runner 1.7 will affect the upgrade of Flink
> runner 1.8x and 1.9x due to the code of Flink 1.7 is too old, more detail
> can be found in [4]. So,  we need to drop the support of Flink runner 1.7
> as soon as possible.
>
> This discussion also CC to @User, due to the change will affect our users.
> And I would appreciate it if you could review the PR [5].
>
> Welcome any feedback!
>
> Best,
> Jincheng
>
> [1]
> http://apache-flink-mailing-list-archive.1008284.n3.nabble.com/ANNOUNCE-Apache-Flin+-1-10-0-released-td37564.html
> <http://apache-flink-mailing-list-archive.1008284.n3.nabble.com/ANNOUNCE-Apache-Flink-1-10-0-released-td37564.html>
> [2] https://issues.apache.org/jira/browse/BEAM-9295
> [3] https://flink.apache.org/downloads.html#update-policy-for-old-releases
> [4] https://issues.apache.org/jira/browse/BEAM-9299
> [5] https://github.com/apache/beam/pull/10884
>
>
>
>

Mime
View raw message