beam-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Bradshaw <rober...@google.com.INVALID>
Subject Re: Renaming SideOutput
Date Tue, 11 Apr 2017 22:52:06 GMT
+1, I think this is a lot clearer.

On Tue, Apr 11, 2017 at 2:24 PM, Stephen Sisk <sisk@google.com.invalid> wrote:
> strong +1 for changing the name away from sideOutput - the fact that
> sideInput and sideOutput are not really related was definitely a source of
> confusion for me when learning beam.
>
> S
>
> On Tue, Apr 11, 2017 at 1:56 PM Thomas Groh <tgroh@google.com.invalid>
> wrote:
>
>> Hey everyone:
>>
>> I'd like to rename DoFn.Context#sideOutput to #output (in the Java SDK).
>>
>> Having two methods, both named output, one which takes the "main output
>> type" and one that takes a tag to specify the type more clearly
>> communicates the actual behavior - sideOutput isn't a "special" way to
>> output, it's the same as output(T), just to a specified PCollection. This
>> will help pipeline authors understand the actual behavior of outputting to
>> a tag, and detangle it from "sideInput", which is a special way to receive
>> input. Giving them the same name means that it's not even strange to call
>> output and provide the main output type, which is what we want - it's a
>> more specific way to output, but does not have different restrictions or
>> capabilities.
>>
>> This is also a pretty small change within the SDK - it touches about 20
>> files, and the changes are pretty automatic.
>>
>> Thanks,
>>
>> Thomas
>>

Mime
View raw message