beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From al...@apache.org
Subject [beam] branch master updated: [BEAM-6827] Update Python dependencies page for 2.10.0, 2.11.0
Date Tue, 19 Mar 2019 00:20:44 GMT
This is an automated email from the ASF dual-hosted git repository.

altay pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/beam.git


The following commit(s) were added to refs/heads/master by this push:
     new 73bac99  [BEAM-6827] Update Python dependencies page for 2.10.0, 2.11.0
     new 2046271  Merge pull request #8050 from melap/dependencies
73bac99 is described below

commit 73bac99af39fde1441608b173e929ac318f8f1d1
Author: Melissa Pashniak <melissapa@google.com>
AuthorDate: Wed Mar 13 14:42:00 2019 -0700

    [BEAM-6827] Update Python dependencies page for 2.10.0, 2.11.0
---
 .../src/documentation/sdks/python-dependencies.md  | 113 ++++++++++++++++++++-
 1 file changed, 111 insertions(+), 2 deletions(-)

diff --git a/website/src/documentation/sdks/python-dependencies.md b/website/src/documentation/sdks/python-dependencies.md
index 11212c7..eebf635 100644
--- a/website/src/documentation/sdks/python-dependencies.md
+++ b/website/src/documentation/sdks/python-dependencies.md
@@ -26,7 +26,81 @@ behavior in the service. If you are using any of these packages in your
code, be
 aware that some libraries are not forward-compatible and you may need to pin to
 the listed versions that will be in scope during execution.
 
-## Current release
+<details open><summary markdown="span">2.11.0</summary>
+
+<p>Beam SDK for Python 2.11.0 has the following compile and
+  runtime dependencies.</p>
+
+<table class="table-bordered table-striped">
+  <tr><th>Package</th><th>Version</th></tr>
+  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version
&gt;= "3.0"</td></tr>
+  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version
&lt; "3.0"</td></tr>
+  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
+  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
+  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
+  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
+  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version
&lt; "3.0"</td></tr>
+  <tr><td>google-apitools</td><td>&gt;=0.5.26,&lt;0.5.27</td></tr>
+  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
+  <tr><td>google-cloud-bigtable</td><td>==0.31.1</td></tr>
+  <tr><td>google-cloud-core</td><td>==0.28.1</td></tr>
+  <tr><td>google-cloud-pubsub</td><td>==0.39.0</td></tr>
+  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version
&lt; "3.0"</td></tr>
+  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
+  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
+  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
+  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
+  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
+  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
+  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
+  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.12.0; python_version
&gt;= "3.0" or platform_system != "Windows"</td></tr>
+  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
+  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
+  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version
&lt; "3.0"</td></tr>
+  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
+  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version
&lt; "3.5.0"</td></tr>
+</table>
+
+</details>
+
+&nbsp;
+
+<details><summary markdown="span">2.10.0</summary>
+
+<p>Beam SDK for Python 2.10.0 has the following compile and
+  runtime dependencies.</p>
+
+<table class="table-bordered table-striped">
+  <tr><th>Package</th><th>Version</th></tr>
+  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version
&gt;= "3.0"</td></tr>
+  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version
&lt; "3.0"</td></tr>
+  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
+  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
+  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
+  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
+  <tr><td>futures</td><td>&gt;=3.1.1,&lt;4.0.0</td></tr>
+  <tr><td>google-apitools</td><td>&gt;=0.5.23,&lt;=0.5.24</td></tr>
+  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
+  <tr><td>google-cloud-pubsub</td><td>==0.39.0</td></tr>
+  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version
&lt; "3.0"</td></tr>
+  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
+  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
+  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
+  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
+  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
+  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
+  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
+  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.12.0; python_version
&gt;= "3.0" or platform_system != "Windows"</td></tr>
+  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
+  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
+  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0</td></tr>
+  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
+  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version
&lt; "3.5.0"</td></tr>
+</table>
+
+</details>
+
+<details><summary markdown="span">2.9.0</summary>
 
 <p>Beam SDK for Python 2.9.0 has the following compile and
   runtime dependencies.</p>
@@ -61,7 +135,7 @@ the listed versions that will be in scope during execution.
   <tr><td>typing</td><td>&gt;=3.6.0, &lt;3.7.0</td></tr>
 </table>
 
-## Previous releases
+</details>
 
 <details><summary markdown="span">2.8.0</summary>
 
@@ -105,6 +179,7 @@ the listed versions that will be in scope during execution.
 
 <p>Beam SDK for Python 2.7.0 has the following compile and
   runtime dependencies.</p>
+
 <table class="table-bordered table-striped">
   <tr><th>Package</th><th>Version</th></tr>
   <tr><td>avro</td><td>&gt;=1.8.1, &lt;2.0.0</td></tr>
@@ -138,3 +213,37 @@ the listed versions that will be in scope during execution.
 
 </details>
 
+<details><summary markdown="span">2.6.0</summary>
+
+<p>Beam SDK for Python 2.6.0 has the following compile and
+  runtime dependencies.</p>
+
+<table class="table-bordered table-striped">
+  <tr><th>Package</th><th>Version</th></tr>
+  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0</td></tr>
+  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
+  <tr><td>dill</td><td>&gt;=0.2.6,&lt;=0.2.8.2</td></tr>
+  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
+  <tr><td>futures</td><td>&gt;=3.1.1,&lt;4.0.0</td></tr>
+  <tr><td>google-apitools</td><td>&gt;=0.5.18,&lt;=0.5.20</td></tr>
+  <tr><td>google-cloud-bigquery</td><td>==0.25.0</td></tr>
+  <tr><td>google-cloud-pubsub</td><td>==0.26.0</td></tr>
+  <tr><td>googledatastore</td><td>==7.0.1</td></tr>
+  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
+  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
+  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
+  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
+  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;5</td></tr>
+  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
+  <tr><td>proto-google-cloud-pubsub-v1</td><td>==0.15.4</td></tr>
+  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
+  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
+  <tr><td>pytz</td><td>&gt;=2018.3,&lt;=2018.4</td></tr>
+  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0</td></tr>
+  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
+  <tr><td>six</td><td>&gt;=1.9,&lt;1.12</td></tr>
+  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0</td></tr>
+</table>
+
+</details>
+


Mime
View raw message