beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PerformanceTests_HadoopInputFormat #535
Date Fri, 20 Jul 2018 00:16:42 GMT
See <https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/535/display/redirect?page=changes>

Changes:

[lcwik] [BEAM-4653] Add support to the Java SDK harness to execute timers.

[amaliujia] BEAM-4820: Add timeout to Future.get when waiting for Pubsub messages

[lcwik] Address PR comments.

[lcwik] Address PR comments.

[jxlewis] Added ClientConfiguration to AwsOptions and S3FileSystem

------------------------------------------
Started by timer
[EnvInject] - Loading node environment variables.
Building remotely on beam8 (beam) in workspace <https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://github.com/apache/beam.git # timeout=10
Fetching upstream changes from https://github.com/apache/beam.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/apache/beam.git +refs/heads/*:refs/remotes/origin/*
+refs/pull/${ghprbPullId}/*:refs/remotes/origin/pr/${ghprbPullId}/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 0e18bf4c81e09c193e113c74cac7301dc26dac9e (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 0e18bf4c81e09c193e113c74cac7301dc26dac9e
Commit message: "Merge pull request #5985 from amaliujia/rui_wang-fix_pubsubIT"
 > git rev-list --no-walk e33852830d863cfa9f9b3250e81afe29b8321d4b # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
SPARK_LOCAL_IP=127.0.0.1

[EnvInject] - Variables injected successfully.
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins7040872982862938990.sh
+ gcloud container clusters get-credentials io-datastores --zone=us-central1-a --verbosity=debug
DEBUG: Running [gcloud.container.clusters.get-credentials] with arguments: [--verbosity: "debug",
--zone: "us-central1-a", NAME: "io-datastores"]
Fetching cluster endpoint and auth data.
DEBUG: Saved kubeconfig to /home/jenkins/.kube/config
kubeconfig entry generated for io-datastores.
INFO: Display format "default".
DEBUG: SDK update checks are disabled.
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins6163123683414681864.sh
+ cp /home/jenkins/.kube/config <https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/config-beam-performancetests-hadoopinputformat-535>
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins7607111520399213742.sh
+ kubectl --kubeconfig=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/config-beam-performancetests-hadoopinputformat-535>
create namespace beam-performancetests-hadoopinputformat-535
namespace "beam-performancetests-hadoopinputformat-535" created
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins6644517011025666463.sh
++ kubectl config current-context
+ kubectl --kubeconfig=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/config-beam-performancetests-hadoopinputformat-535>
config set-context gke_apache-beam-testing_us-central1-a_io-datastores --namespace=beam-performancetests-hadoopinputformat-535
Context "gke_apache-beam-testing_us-central1-a_io-datastores" modified.
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins7035852227243632070.sh
+ rm -rf PerfKitBenchmarker
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins2836472724981303912.sh
+ rm -rf .env
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins8792526416535801369.sh
+ virtualenv .env --system-site-packages
New python executable in <https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/.env/bin/python2>
Also creating executable in <https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/.env/bin/python>
Installing setuptools, pkg_resources, pip, wheel...done.
Running virtualenv with interpreter /usr/bin/python2
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins5324281738854189608.sh
+ .env/bin/pip install --upgrade setuptools pip
Requirement already up-to-date: setuptools in ./.env/lib/python2.7/site-packages (40.0.0)
Requirement already up-to-date: pip in ./.env/lib/python2.7/site-packages (10.0.1)
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins1577586122083092265.sh
+ git clone https://github.com/GoogleCloudPlatform/PerfKitBenchmarker.git
Cloning into 'PerfKitBenchmarker'...
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins6961261101008092930.sh
+ .env/bin/pip install -r PerfKitBenchmarker/requirements.txt
Collecting absl-py (from -r PerfKitBenchmarker/requirements.txt (line 14))
Requirement already satisfied: jinja2>=2.7 in /usr/local/lib/python2.7/dist-packages (from
-r PerfKitBenchmarker/requirements.txt (line 15)) (2.10)
Requirement already satisfied: setuptools in ./.env/lib/python2.7/site-packages (from -r PerfKitBenchmarker/requirements.txt
(line 16)) (40.0.0)
Collecting colorlog[windows]==2.6.0 (from -r PerfKitBenchmarker/requirements.txt (line 17))
  Using cached https://files.pythonhosted.org/packages/59/1a/46a1bf2044ad8b30b52fed0f389338c85747e093fe7f51a567f4cb525892/colorlog-2.6.0-py2.py3-none-any.whl
Collecting blinker>=1.3 (from -r PerfKitBenchmarker/requirements.txt (line 18))
Collecting futures>=3.0.3 (from -r PerfKitBenchmarker/requirements.txt (line 19))
  Using cached https://files.pythonhosted.org/packages/2d/99/b2c4e9d5a30f6471e410a146232b4118e697fa3ffc06d6a65efde84debd0/futures-3.2.0-py2-none-any.whl
Requirement already satisfied: PyYAML==3.12 in /usr/local/lib/python2.7/dist-packages (from
-r PerfKitBenchmarker/requirements.txt (line 20)) (3.12)
Collecting pint>=0.7 (from -r PerfKitBenchmarker/requirements.txt (line 21))
Collecting numpy==1.13.3 (from -r PerfKitBenchmarker/requirements.txt (line 22))
  Using cached https://files.pythonhosted.org/packages/eb/be/737f3df5806192ac4096e549e48c8c76cfaa2fb880a1c62a7bb085adaa9b/numpy-1.13.3-cp27-cp27mu-manylinux1_x86_64.whl
Requirement already satisfied: functools32 in /usr/local/lib/python2.7/dist-packages (from
-r PerfKitBenchmarker/requirements.txt (line 23)) (3.2.3.post2)
Collecting contextlib2>=0.5.1 (from -r PerfKitBenchmarker/requirements.txt (line 24))
  Using cached https://files.pythonhosted.org/packages/a2/71/8273a7eeed0aff6a854237ab5453bc9aa67deb49df4832801c21f0ff3782/contextlib2-0.5.5-py2.py3-none-any.whl
Collecting pywinrm (from -r PerfKitBenchmarker/requirements.txt (line 25))
  Using cached https://files.pythonhosted.org/packages/0d/12/13a3117bbd2230043aa32dcfa2198c33269665eaa1a8fa26174ce49b338f/pywinrm-0.3.0-py2.py3-none-any.whl
Collecting timeout-decorator (from -r PerfKitBenchmarker/requirements.txt (line 26))
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from absl-py->-r
PerfKitBenchmarker/requirements.txt (line 14)) (1.11.0)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python2.7/dist-packages
(from jinja2>=2.7->-r PerfKitBenchmarker/requirements.txt (line 15)) (1.0)
Collecting colorama; extra == "windows" (from colorlog[windows]==2.6.0->-r PerfKitBenchmarker/requirements.txt
(line 17))
  Using cached https://files.pythonhosted.org/packages/db/c8/7dcf9dbcb22429512708fe3a547f8b6101c0d02137acbd892505aee57adf/colorama-0.3.9-py2.py3-none-any.whl
Collecting requests-ntlm>=0.3.0 (from pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25))
  Using cached https://files.pythonhosted.org/packages/03/4b/8b9a1afde8072c4d5710d9fa91433d504325821b038e00237dc8d6d833dc/requests_ntlm-1.1.0-py2.py3-none-any.whl
Requirement already satisfied: requests>=2.9.1 in /usr/local/lib/python2.7/dist-packages
(from pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25)) (2.18.4)
Collecting xmltodict (from pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
  Using cached https://files.pythonhosted.org/packages/42/a9/7e99652c6bc619d19d58cdd8c47560730eb5825d43a7e25db2e1d776ceb7/xmltodict-0.11.0-py2.py3-none-any.whl
Requirement already satisfied: cryptography>=1.3 in /usr/local/lib/python2.7/dist-packages
(from requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt (line
25)) (2.2.2)
Collecting ntlm-auth>=1.0.2 (from requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25))
  Using cached https://files.pythonhosted.org/packages/8e/5b/4047779fb456b0de503c4acb7b166becf2567efb772abb53998440791d3c/ntlm_auth-1.2.0-py2.py3-none-any.whl
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(2018.4.16)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(3.0.4)
Requirement already satisfied: idna<2.7,>=2.5 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(2.6)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(1.22)
Requirement already satisfied: cffi>=1.7; platform_python_implementation != "PyPy" in /usr/local/lib/python2.7/dist-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (1.11.5)
Requirement already satisfied: enum34; python_version < "3" in /usr/local/lib/python2.7/dist-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (1.1.6)
Requirement already satisfied: asn1crypto>=0.21.0 in /usr/local/lib/python2.7/dist-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (0.24.0)
Requirement already satisfied: ipaddress; python_version < "3" in /usr/local/lib/python2.7/dist-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (1.0.22)
Requirement already satisfied: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.7;
platform_python_implementation != "PyPy"->cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r
PerfKitBenchmarker/requirements.txt (line 25)) (2.18)
Installing collected packages: absl-py, colorama, colorlog, blinker, futures, pint, numpy,
contextlib2, ntlm-auth, requests-ntlm, xmltodict, pywinrm, timeout-decorator
Successfully installed absl-py-0.2.2 blinker-1.4 colorama-0.3.9 colorlog-2.6.0 contextlib2-0.5.5
futures-3.2.0 ntlm-auth-1.2.0 numpy-1.13.3 pint-0.8.1 pywinrm-0.3.0 requests-ntlm-1.1.0 timeout-decorator-0.4.0
xmltodict-0.11.0
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins9188183398149536686.sh
+ .env/bin/pip install -e 'src/sdks/python/[gcp,test]'
Obtaining file://<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src/sdks/python>
Collecting avro<2.0.0,>=1.8.1 (from apache-beam==2.7.0.dev0)
Requirement already satisfied: crcmod<2.0,>=1.7 in /usr/lib/python2.7/dist-packages
(from apache-beam==2.7.0.dev0) (1.7)
Collecting dill<=0.2.8.2,>=0.2.6 (from apache-beam==2.7.0.dev0)
Collecting grpcio<2,>=1.8 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/fa/53/685b9d68e5734cf8e2d13b2d4d29e6cede94714b665019a5627a623b3e21/grpcio-1.13.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting hdfs<3.0.0,>=2.1.0 (from apache-beam==2.7.0.dev0)
Collecting httplib2<=0.11.3,>=0.8 (from apache-beam==2.7.0.dev0)
Collecting mock<3.0.0,>=1.0.1 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/e6/35/f187bdf23be87092bd0f1200d43d23076cee4d0dec109f195173fd3ebc79/mock-2.0.0-py2.py3-none-any.whl
Collecting oauth2client<5,>=2.0.1 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/82/d8/3eab58811282ac7271a081ba5c0d4b875ce786ca68ce43e2a62ade32e9a8/oauth2client-4.1.2-py2.py3-none-any.whl
Collecting protobuf<4,>=3.5.0.post1 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/27/e7/bf96130ebe633b08a3913da4bb25e50dac5779f1f68e51c99485423f7443/protobuf-3.6.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting pydot<1.3,>=1.2.0 (from apache-beam==2.7.0.dev0)
Collecting pytz<=2018.4,>=2018.3 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/dc/83/15f7833b70d3e067ca91467ca245bae0f6fe56ddc7451aa0dc5606b120f2/pytz-2018.4-py2.py3-none-any.whl
Requirement already satisfied: pyyaml<4.0.0,>=3.12 in /usr/local/lib/python2.7/dist-packages
(from apache-beam==2.7.0.dev0) (3.12)
Collecting pyvcf<0.7.0,>=0.6.8 (from apache-beam==2.7.0.dev0)
Requirement already satisfied: six<1.12,>=1.9 in /usr/local/lib/python2.7/dist-packages
(from apache-beam==2.7.0.dev0) (1.11.0)
Collecting typing<3.7.0,>=3.6.0 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/0d/4d/4e5985d075d241d686a1663fa1f88b61d544658d08c1375c7c6aac32afc3/typing-3.6.4-py2-none-any.whl
Requirement already satisfied: futures<4.0.0,>=3.1.1 in ./.env/lib/python2.7/site-packages
(from apache-beam==2.7.0.dev0) (3.2.0)
Collecting future<1.0.0,>=0.16.0 (from apache-beam==2.7.0.dev0)
Collecting fastavro==0.19.7 (from apache-beam==2.7.0.dev0)
Collecting google-apitools<=0.5.20,>=0.5.18 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/1d/0c/64f84f91643f775fdb64c6c10f4a4f0d827f8b0d98a2ba2b4bb9dc2f8646/google_apitools-0.5.20-py2-none-any.whl
Collecting proto-google-cloud-datastore-v1<=0.90.4,>=0.90.0 (from apache-beam==2.7.0.dev0)
Collecting googledatastore==7.0.1 (from apache-beam==2.7.0.dev0)
Collecting google-cloud-pubsub==0.26.0 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/37/92/c74a643126d58505daec9addf872dfaffea3305981b90cc435f4b9213cdd/google_cloud_pubsub-0.26.0-py2.py3-none-any.whl
Collecting proto-google-cloud-pubsub-v1==0.15.4 (from apache-beam==2.7.0.dev0)
Collecting google-cloud-bigquery==0.25.0 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/76/67/6165c516ff6ceaa62eb61f11d8451e1b0acc4d3775e181630aba9652babb/google_cloud_bigquery-0.25.0-py2.py3-none-any.whl
Collecting nose>=1.3.7 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/99/4f/13fb671119e65c4dce97c60e67d3fd9e6f7f809f2b307e2611f4701205cb/nose-1.3.7-py2-none-any.whl
Collecting numpy<2,>=1.14.3 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/6a/a9/c01a2d5f7b045f508c8cefef3b079fe8c413d05498ca0ae877cffa230564/numpy-1.14.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting pyhamcrest<2.0,>=1.9 (from apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/9a/d5/d37fd731b7d0e91afcc84577edeccf4638b4f9b82f5ffe2f8b62e2ddc609/PyHamcrest-1.9.0-py2.py3-none-any.whl
Requirement already satisfied: enum34>=1.0.4 in /usr/local/lib/python2.7/dist-packages
(from grpcio<2,>=1.8->apache-beam==2.7.0.dev0) (1.1.6)
Requirement already satisfied: docopt in /usr/local/lib/python2.7/dist-packages (from hdfs<3.0.0,>=2.1.0->apache-beam==2.7.0.dev0)
(0.6.2)
Requirement already satisfied: requests>=2.7.0 in /usr/local/lib/python2.7/dist-packages
(from hdfs<3.0.0,>=2.1.0->apache-beam==2.7.0.dev0) (2.18.4)
Requirement already satisfied: pbr>=0.11 in /usr/lib/python2.7/dist-packages (from mock<3.0.0,>=1.0.1->apache-beam==2.7.0.dev0)
(1.8.0)
Collecting funcsigs>=1; python_version < "3.3" (from mock<3.0.0,>=1.0.1->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Requirement already satisfied: pyasn1>=0.1.7 in /usr/local/lib/python2.7/dist-packages
(from oauth2client<5,>=2.0.1->apache-beam==2.7.0.dev0) (0.4.2)
Collecting pyasn1-modules>=0.0.5 (from oauth2client<5,>=2.0.1->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/19/02/fa63f7ba30a0d7b925ca29d034510fc1ffde53264b71b4155022ddf3ab5d/pyasn1_modules-0.2.2-py2.py3-none-any.whl
Collecting rsa>=3.1.4 (from oauth2client<5,>=2.0.1->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/e1/ae/baedc9cb175552e95f3395c43055a6a5e125ae4d48a1d7a924baca83e92e/rsa-3.4.2-py2.py3-none-any.whl
Requirement already satisfied: setuptools in ./.env/lib/python2.7/site-packages (from protobuf<4,>=3.5.0.post1->apache-beam==2.7.0.dev0)
(40.0.0)
Collecting pyparsing>=2.1.4 (from pydot<1.3,>=1.2.0->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/6a/8a/718fd7d3458f9fab8e67186b00abdd345b639976bc7fb3ae722e1b026a50/pyparsing-2.2.0-py2.py3-none-any.whl
Collecting fasteners>=0.14 (from google-apitools<=0.5.20,>=0.5.18->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/14/3a/096c7ad18e102d4f219f5dd15951f9728ca5092a3385d2e8f79a7c1e1017/fasteners-0.14.1-py2.py3-none-any.whl
Collecting googleapis-common-protos<2.0dev,>=1.5.2 (from proto-google-cloud-datastore-v1<=0.90.4,>=0.90.0->apache-beam==2.7.0.dev0)
Collecting gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0 (from google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
Collecting google-cloud-core<0.26dev,>=0.25.0 (from google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/ef/dd/00e90bd1f6788f06ca5ea83a0ec8dd76350b38303bb8f09d2bf692eb1294/google_cloud_core-0.25.0-py2.py3-none-any.whl
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.7.0.dev0) (2018.4.16)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.7.0.dev0) (3.0.4)
Requirement already satisfied: idna<2.7,>=2.5 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.7.0.dev0) (2.6)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in /usr/local/lib/python2.7/dist-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.7.0.dev0) (1.22)
Collecting monotonic>=0.1 (from fasteners>=0.14->google-apitools<=0.5.20,>=0.5.18->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/ac/aa/063eca6a416f397bd99552c534c6d11d57f58f2e94c14780f3bbf818c4cf/monotonic-1.5-py2.py3-none-any.whl
Collecting google-gax<0.16dev,>=0.15.7 (from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/4f/b4/ff312fa42f91535c67567c1d08e972db0e7c548e9a63c6f3bcc5213b32fc/google_gax-0.15.16-py2.py3-none-any.whl
Collecting grpc-google-iam-v1<0.12dev,>=0.11.1 (from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
Collecting google-auth-httplib2 (from google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/33/49/c814d6d438b823441552198f096fcd0377fd6c88714dbed34f1d3c8c4389/google_auth_httplib2-0.0.3-py2.py3-none-any.whl
Collecting google-auth<2.0.0dev,>=0.4.0 (from google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/53/06/6e6d5bfa4d23ee40efd772d6b681a7afecd859a9176e564b8c329382370f/google_auth-1.5.0-py2.py3-none-any.whl
Collecting ply==3.8 (from google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
Collecting cachetools>=2.0.0 (from google-auth<2.0.0dev,>=0.4.0->google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.7.0.dev0)
  Using cached https://files.pythonhosted.org/packages/0a/58/cbee863250b31d80f47401d04f34038db6766f95dea1cc909ea099c7e571/cachetools-2.1.0-py2.py3-none-any.whl
gapic-google-cloud-pubsub-v1 0.15.4 has requirement oauth2client<4.0dev,>=2.0.0, but
you'll have oauth2client 4.1.2 which is incompatible.
proto-google-cloud-datastore-v1 0.90.4 has requirement oauth2client<4.0dev,>=2.0.0,
but you'll have oauth2client 4.1.2 which is incompatible.
proto-google-cloud-pubsub-v1 0.15.4 has requirement oauth2client<4.0dev,>=2.0.0, but
you'll have oauth2client 4.1.2 which is incompatible.
googledatastore 7.0.1 has requirement httplib2<0.10,>=0.9.1, but you'll have httplib2
0.11.3 which is incompatible.
googledatastore 7.0.1 has requirement oauth2client<4.0.0,>=2.0.1, but you'll have oauth2client
4.1.2 which is incompatible.
Installing collected packages: avro, dill, grpcio, hdfs, httplib2, funcsigs, mock, pyasn1-modules,
rsa, oauth2client, protobuf, pyparsing, pydot, pytz, pyvcf, typing, future, fastavro, monotonic,
fasteners, google-apitools, googleapis-common-protos, proto-google-cloud-datastore-v1, googledatastore,
proto-google-cloud-pubsub-v1, ply, cachetools, google-auth, google-gax, grpc-google-iam-v1,
gapic-google-cloud-pubsub-v1, google-auth-httplib2, google-cloud-core, google-cloud-pubsub,
google-cloud-bigquery, nose, numpy, pyhamcrest, apache-beam
  Found existing installation: numpy 1.13.3
    Uninstalling numpy-1.13.3:
      Successfully uninstalled numpy-1.13.3
  Running setup.py develop for apache-beam
Successfully installed apache-beam avro-1.8.2 cachetools-2.1.0 dill-0.2.8.2 fastavro-0.19.7
fasteners-0.14.1 funcsigs-1.0.2 future-0.16.0 gapic-google-cloud-pubsub-v1-0.15.4 google-apitools-0.5.20
google-auth-1.5.0 google-auth-httplib2-0.0.3 google-cloud-bigquery-0.25.0 google-cloud-core-0.25.0
google-cloud-pubsub-0.26.0 google-gax-0.15.16 googleapis-common-protos-1.5.3 googledatastore-7.0.1
grpc-google-iam-v1-0.11.4 grpcio-1.13.0 hdfs-2.1.0 httplib2-0.11.3 mock-2.0.0 monotonic-1.5
nose-1.3.7 numpy-1.14.5 oauth2client-4.1.2 ply-3.8 proto-google-cloud-datastore-v1-0.90.4
proto-google-cloud-pubsub-v1-0.15.4 protobuf-3.6.0 pyasn1-modules-0.2.2 pydot-1.2.4 pyhamcrest-1.9.0
pyparsing-2.2.0 pytz-2018.4 pyvcf-0.6.8 rsa-3.4.2 typing-3.6.4
[beam_PerformanceTests_HadoopInputFormat] $ /bin/bash -xe /tmp/jenkins7544477713671113495.sh
+ .env/bin/python PerfKitBenchmarker/pkb.py --project=apache-beam-testing --dpb_log_level=INFO
--bigquery_table=beam_performance.hadoopinputformatioit_pkb_results --k8s_get_retry_count=36
--k8s_get_wait_interval=10 --temp_dir=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/>
--beam_location=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src>
--official=true --kubeconfig=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/config-beam-performancetests-hadoopinputformat-535>
--beam_it_timeout=1200 --benchmarks=beam_integration_benchmark --beam_prebuilt=false --beam_sdk=java
--beam_it_module=sdks/java/io/hadoop-input-format --beam_it_class=org.apache.beam.sdk.io.hadoop.inputformat.HadoopInputFormatIOIT
'--beam_it_options=[--tempRoot=gs://temp-storage-for-perf-tests,--project=apache-beam-testing,--postgresPort=5432,--numberOfRecords=600000]'
--beam_kubernetes_scripts=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src/.test-infra/kubernetes/postgres/postgres-service-for-local-dev.yml>
--beam_options_config_file=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src/.test-infra/kubernetes/postgres/pkb-config-local.yml>
2018-07-20 00:16:42,162 a2d4af09 MainThread INFO     Verbose logging to: <https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/runs/a2d4af09/pkb.log>
2018-07-20 00:16:42,163 a2d4af09 MainThread INFO     PerfKitBenchmarker version: v1.12.0-725-g3cd3e81
2018-07-20 00:16:42,163 a2d4af09 MainThread INFO     Flag values:
--beam_it_class=org.apache.beam.sdk.io.hadoop.inputformat.HadoopInputFormatIOIT
--beam_it_timeout=1200
--beam_it_module=sdks/java/io/hadoop-input-format
--beam_sdk=java
--k8s_get_wait_interval=10
--temp_dir=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/>
--beam_it_options=[--tempRoot=gs://temp-storage-for-perf-tests,--project=apache-beam-testing,--postgresPort=5432,--numberOfRecords=600000]
--nobeam_prebuilt
--kubeconfig=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/config-beam-performancetests-hadoopinputformat-535>
--project=apache-beam-testing
--beam_kubernetes_scripts=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src/.test-infra/kubernetes/postgres/postgres-service-for-local-dev.yml>
--bigquery_table=beam_performance.hadoopinputformatioit_pkb_results
--official
--dpb_log_level=INFO
--beam_options_config_file=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src/.test-infra/kubernetes/postgres/pkb-config-local.yml>
--beam_location=<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/src>
--k8s_get_retry_count=36
--benchmarks=beam_integration_benchmark
Traceback (most recent call last):
  File "PerfKitBenchmarker/pkb.py", line 21, in <module>
    sys.exit(Main())
  File "<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/PerfKitBenchmarker/perfkitbenchmarker/pkb.py",>
line 999, in Main
    SetUpPKB()
  File "<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/PerfKitBenchmarker/perfkitbenchmarker/pkb.py",>
line 861, in SetUpPKB
    requirements.CheckBasicRequirements()
  File "<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/PerfKitBenchmarker/perfkitbenchmarker/requirements.py",>
line 74, in CheckBasicRequirements
    _CheckRequirements(requirements_file_path)
  File "<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/PerfKitBenchmarker/perfkitbenchmarker/requirements.py",>
line 60, in _CheckRequirements
    linesep=os.linesep, msg=err_msg, path=requirements_file_path))
perfkitbenchmarker.errors.PythonPackageRequirementUnfulfilled: A Python package requirement
was not met while checking "<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/PerfKitBenchmarker/requirements.txt">:
numpy 1.14.5 is installed but numpy==1.13.3 is required
To install required packages, execute the following command:
pip install -r "<https://builds.apache.org/job/beam_PerformanceTests_HadoopInputFormat/ws/PerfKitBenchmarker/requirements.txt">
To bypass package requirement checks, run PerfKit Benchmarker with the --ignore_package_requirements
flag.
Build step 'Execute shell' marked build as failure

Mime
View raw message