beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kamil Szewczyk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BEAM-4362) Kubectl version on beam executors must be upgraded to at least 1.9.3
Date Fri, 18 May 2018 14:22:00 GMT
Kamil Szewczyk created BEAM-4362:
------------------------------------

             Summary: Kubectl version on beam executors must be upgraded to at least 1.9.3
                 Key: BEAM-4362
                 URL: https://issues.apache.org/jira/browse/BEAM-4362
             Project: Beam
          Issue Type: Improvement
          Components: build-system
            Reporter: Kamil Szewczyk
            Assignee: Luke Cwik


Currently beam inventory jobs [https://builds.apache.org/view/A-D/view/Beam/job/beam_Inventory_beam1/57/console] shows
that we are using:
+ kubectl version -c
Flag shorthand -c has been deprecated, please use --client instead.
Client Version: version.Info{Major:"1", Minor:"9", GitVersion:"v1.9.0", GitCommit:"925c127ec6b946659ad0fd596fa959be43f0cc05",
GitTreeState:"clean", BuildDate:"2017-12-15T21:07:38Z", GoVersion:"go1.9.2", Compiler:"gc",
Platform:"linux/amd64"
This kubectl version is old and doesn't allow us to fully use [https://kubernetes.io/docs/concepts/workloads/controllers/statefulset/] which
will be used by complex large clusters like hdfs/hbase. 

Without this upgrade to at least 1.9.3 version we can expect this error:
[https://github.com/kubernetes/kubernetes/issues/59867

]Minor: can we also print server version in beam inventory job by running:
kubectl version 
instead of just kubectl version -c ?? 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message