beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henning Rohde (JIRA)" <>
Subject [jira] [Closed] (BEAM-3829) Update Go SDK to use latest BQ version
Date Sun, 11 Mar 2018 18:04:00 GMT


Henning Rohde closed BEAM-3829.
       Resolution: Not A Bug
    Fix Version/s: Not applicable

My thought-to-be-clean workspace actually had an old version of BQ, which was the problem
and so there is no bug.

> Update Go SDK to use latest BQ version
> --------------------------------------
>                 Key: BEAM-3829
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-go
>            Reporter: Henning Rohde
>            Priority: Major
>             Fix For: Not applicable
> We should update BQ to the latest version, so that "go get" works cleanly:
> $ go get
> #
> ../../apache/beam/sdks/go/pkg/beam/io/bigqueryio/bigquery.go:120:3: q.UseLegacySQL undefined
(type *"".Query has no field or method UseLegacySQL)
> ../../apache/beam/sdks/go/pkg/beam/io/bigqueryio/bigquery.go:204:61: cannot use "".TableMetadata
literal (type *"".TableMetadata) as type "".CreateTableOption
in argument to table.Create:
> 	*"".TableMetadata does not implement "".CreateTableOption
(missing "".customizeCreateTable method)
> Edit: If we can't use legacy SQL, then our parsing of table name also needs to change.

This message was sent by Atlassian JIRA

View raw message