beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PostCommit_Python_Verify #3740
Date Fri, 15 Dec 2017 21:16:14 GMT
See <https://builds.apache.org/job/beam_PostCommit_Python_Verify/3740/display/redirect>

------------------------------------------
[...truncated 158.97 KB...]
Collecting pyhamcrest<2.0,>=1.9 (from apache-beam==2.3.0.dev0)
  Using cached PyHamcrest-1.9.0-py2.py3-none-any.whl
Requirement already satisfied: enum34>=1.0.4 in ./target/.tox/lint/lib/python2.7/site-packages
(from grpcio<2.0,>=1.0->apache-beam==2.3.0.dev0)
Requirement already satisfied: pbr>=0.11 in ./target/.tox/lint/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in ./target/.tox/lint/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: rsa>=3.1.4 in ./target/.tox/lint/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1-modules>=0.0.5 in ./target/.tox/lint/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1>=0.1.7 in ./target/.tox/lint/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: setuptools in ./target/.tox/lint/lib/python2.7/site-packages
(from protobuf<=3.3.0,>=3.2.0->apache-beam==2.3.0.dev0)
Installing collected packages: pyhamcrest, apache-beam
  Found existing installation: apache-beam 2.3.0.dev0
    Uninstalling apache-beam-2.3.0.dev0:
      Successfully uninstalled apache-beam-2.3.0.dev0
  Running setup.py develop for apache-beam
Successfully installed apache-beam pyhamcrest-1.9.0
2.50user 0.39system 0:03.38elapsed 85%CPU (0avgtext+0avgdata 34644maxresident)k
0inputs+2432outputs (0major+49741minor)pagefaults 0swaps
lint runtests: commands[1] | time <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/run_pylint.sh>
Skipping lint for generated files: bigquery_v2_client.py, bigquery_v2_messages.py, dataflow_v1b3_client.py,
dataflow_v1b3_messages.py, storage_v1_client.py, storage_v1_messages.py, proto2_coder_test_messages_pb2.py,
beam_artifact_api_pb2_grpc.py, beam_artifact_api_pb2.py, beam_fn_api_pb2_grpc.py, beam_fn_api_pb2.py,
beam_job_api_pb2_grpc.py, beam_job_api_pb2.py, beam_provision_api_pb2_grpc.py, beam_provision_api_pb2.py,
beam_runner_api_pb2_grpc.py, beam_runner_api_pb2.py, endpoints_pb2_grpc.py, endpoints_pb2.py,
standard_window_fns_pb2_grpc.py, standard_window_fns_pb2.py
Running pylint for module apache_beam:

--------------------------------------------------------------------
Your code has been rated at 10.00/10 (previous run: 10.00/10, +0.00)

Running pycodestyle for module apache_beam:
Running isort for module apache_beam:
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam>
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python>
Skipped 69 files
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python>
Checking for files requiring stage 1 refactoring from futurize
No future changes needed
300.72user 5.60system 5:39.27elapsed 90%CPU (0avgtext+0avgdata 242212maxresident)k
3896inputs+160outputs (0major+641185minor)pagefaults 0swaps
py27 create: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27>
py27 installdeps: nose==1.3.7, grpcio-tools==1.3.5
py27 inst: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/dist/apache-beam-2.3.0.dev.zip>
py27 installed: apache-beam==2.3.0.dev0,avro==1.8.2,crcmod==1.7,dill==0.2.6,enum34==1.1.6,funcsigs==1.0.2,futures==3.2.0,grpcio==1.8.1,grpcio-tools==1.3.5,httplib2==0.9.2,mock==2.0.0,nose==1.3.7,oauth2client==3.0.0,pbr==3.1.1,protobuf==3.3.0,pyasn1==0.4.2,pyasn1-modules==0.2.1,PyVCF==0.6.8,PyYAML==3.12,rsa==3.4.2,six==1.10.0,typing==3.6.2
py27 runtests: PYTHONHASHSEED='2681863654'
py27 runtests: commands[0] | python --version
Python 2.7.6
py27 runtests: commands[1] | - find apache_beam -type f -name *.pyc -delete
py27 runtests: commands[2] | pip install -e .[test]
Obtaining file://<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python>
Requirement already satisfied: avro<2.0.0,>=1.8.1 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: crcmod<2.0,>=1.7 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: dill==0.2.6 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: grpcio<2.0,>=1.0 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: httplib2<0.10,>=0.8 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: mock<3.0.0,>=1.0.1 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: oauth2client<4.0.0,>=2.0.1 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: protobuf<=3.3.0,>=3.2.0 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: pyyaml<4.0.0,>=3.12 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: pyvcf<0.7.0,>=0.6.8 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: six<1.11,>=1.9 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: typing<3.7.0,>=3.6.0 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: futures<4.0.0,>=3.1.1 in ./target/.tox/py27/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Collecting pyhamcrest<2.0,>=1.9 (from apache-beam==2.3.0.dev0)
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:318:
SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension
to TLS is not available on this platform. This may cause the server to present an incorrect
TLS certificate, which can cause validation failures. You can upgrade to a newer version of
Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:122:
InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3
from configuring SSL appropriately and may cause certain SSL connections to fail. You can
upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Using cached PyHamcrest-1.9.0-py2.py3-none-any.whl
Requirement already satisfied: enum34>=1.0.4 in ./target/.tox/py27/lib/python2.7/site-packages
(from grpcio<2.0,>=1.0->apache-beam==2.3.0.dev0)
Requirement already satisfied: pbr>=0.11 in ./target/.tox/py27/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in ./target/.tox/py27/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: rsa>=3.1.4 in ./target/.tox/py27/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1-modules>=0.0.5 in ./target/.tox/py27/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1>=0.1.7 in ./target/.tox/py27/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: setuptools in ./target/.tox/py27/lib/python2.7/site-packages
(from protobuf<=3.3.0,>=3.2.0->apache-beam==2.3.0.dev0)
Installing collected packages: pyhamcrest, apache-beam
  Found existing installation: apache-beam 2.3.0.dev0
    Uninstalling apache-beam-2.3.0.dev0:
      Successfully uninstalled apache-beam-2.3.0.dev0
  Running setup.py develop for apache-beam
Successfully installed apache-beam pyhamcrest-1.9.0
py27 runtests: commands[3] | python apache_beam/examples/complete/autocomplete_test.py
Traceback (most recent call last):
  File "apache_beam/examples/complete/autocomplete_test.py", line 22, in <module>
    import apache_beam as beam
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/__init__.py",>
line 86, in <module>
    from apache_beam import coders
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/coders/__init__.py",>
line 18, in <module>
    from apache_beam.coders.coders import *
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/coders/coders.py",>
line 30, in <module>
    from apache_beam.portability.api import beam_runner_api_pb2
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/portability/api/beam_runner_api_pb2.py",>
line 313, in <module>
    options=None, file=DESCRIPTOR),
TypeError: __new__() got an unexpected keyword argument 'file'
ERROR: InvocationError: '<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27/bin/python>
apache_beam/examples/complete/autocomplete_test.py'
py27cython create: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27cython>
py27cython installdeps: nose==1.3.7, grpcio-tools==1.3.5, cython==0.25.2
py27cython inst: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/dist/apache-beam-2.3.0.dev.zip>
py27cython installed: apache-beam==2.3.0.dev0,avro==1.8.2,crcmod==1.7,Cython==0.25.2,dill==0.2.6,enum34==1.1.6,funcsigs==1.0.2,futures==3.2.0,grpcio==1.8.1,grpcio-tools==1.3.5,httplib2==0.9.2,mock==2.0.0,nose==1.3.7,oauth2client==3.0.0,pbr==3.1.1,protobuf==3.3.0,pyasn1==0.4.2,pyasn1-modules==0.2.1,PyVCF==0.6.8,PyYAML==3.12,rsa==3.4.2,six==1.10.0,typing==3.6.2
py27cython runtests: PYTHONHASHSEED='2681863654'
py27cython runtests: commands[0] | python --version
Python 2.7.6
py27cython runtests: commands[1] | - find apache_beam -type f -name *.pyc -delete
py27cython runtests: commands[2] | - find apache_beam -type f -name *.c -delete
py27cython runtests: commands[3] | - find apache_beam -type f -name *.so -delete
py27cython runtests: commands[4] | - find target/build -type f -name *.c -delete
/usr/bin/find: `target/build': No such file or directory
py27cython runtests: commands[5] | - find target/build -type f -name *.so -delete
/usr/bin/find: `target/build': No such file or directory
py27cython runtests: commands[6] | time pip install -e .[test]
Obtaining file://<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python>
Requirement already satisfied: avro<2.0.0,>=1.8.1 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: crcmod<2.0,>=1.7 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: dill==0.2.6 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: grpcio<2.0,>=1.0 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: httplib2<0.10,>=0.8 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: mock<3.0.0,>=1.0.1 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: oauth2client<4.0.0,>=2.0.1 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: protobuf<=3.3.0,>=3.2.0 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: pyyaml<4.0.0,>=3.12 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: pyvcf<0.7.0,>=0.6.8 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: six<1.11,>=1.9 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: typing<3.7.0,>=3.6.0 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: futures<4.0.0,>=3.1.1 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Collecting pyhamcrest<2.0,>=1.9 (from apache-beam==2.3.0.dev0)
  Using cached PyHamcrest-1.9.0-py2.py3-none-any.whl
Requirement already satisfied: enum34>=1.0.4 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from grpcio<2.0,>=1.0->apache-beam==2.3.0.dev0)
Requirement already satisfied: pbr>=0.11 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in ./target/.tox/py27cython/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: rsa>=3.1.4 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1-modules>=0.0.5 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1>=0.1.7 in ./target/.tox/py27cython/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: setuptools in ./target/.tox/py27cython/lib/python2.7/site-packages
(from protobuf<=3.3.0,>=3.2.0->apache-beam==2.3.0.dev0)
Installing collected packages: pyhamcrest, apache-beam
  Found existing installation: apache-beam 2.3.0.dev0
    Uninstalling apache-beam-2.3.0.dev0:
      Successfully uninstalled apache-beam-2.3.0.dev0
  Running setup.py develop for apache-beam
Successfully installed apache-beam pyhamcrest-1.9.0
64.51user 1.63system 1:13.18elapsed 90%CPU (0avgtext+0avgdata 246712maxresident)k
72inputs+138288outputs (0major+465583minor)pagefaults 0swaps
py27cython runtests: commands[7] | python apache_beam/examples/complete/autocomplete_test.py
Traceback (most recent call last):
  File "apache_beam/examples/complete/autocomplete_test.py", line 22, in <module>
    import apache_beam as beam
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/__init__.py",>
line 86, in <module>
    from apache_beam import coders
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/coders/__init__.py",>
line 18, in <module>
    from apache_beam.coders.coders import *
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/coders/coders.py",>
line 30, in <module>
    from apache_beam.portability.api import beam_runner_api_pb2
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/portability/api/beam_runner_api_pb2.py",>
line 313, in <module>
    options=None, file=DESCRIPTOR),
TypeError: __new__() got an unexpected keyword argument 'file'
ERROR: InvocationError: '<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27cython/bin/python>
apache_beam/examples/complete/autocomplete_test.py'
py27gcp create: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27gcp>
py27gcp installdeps: nose==1.3.7
py27gcp inst: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/dist/apache-beam-2.3.0.dev.zip>
py27gcp installed: apache-beam==2.3.0.dev0,avro==1.8.2,crcmod==1.7,dill==0.2.6,enum34==1.1.6,funcsigs==1.0.2,futures==3.2.0,grpcio==1.8.1,httplib2==0.9.2,mock==2.0.0,nose==1.3.7,oauth2client==3.0.0,pbr==3.1.1,protobuf==3.3.0,pyasn1==0.4.2,pyasn1-modules==0.2.1,PyVCF==0.6.8,PyYAML==3.12,rsa==3.4.2,six==1.10.0,typing==3.6.2
py27gcp runtests: PYTHONHASHSEED='2681863654'
py27gcp runtests: commands[0] | pip install -e .[test,gcp]
Obtaining file://<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python>
Requirement already satisfied: avro<2.0.0,>=1.8.1 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: crcmod<2.0,>=1.7 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: dill==0.2.6 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: grpcio<2.0,>=1.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: httplib2<0.10,>=0.8 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: mock<3.0.0,>=1.0.1 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: oauth2client<4.0.0,>=2.0.1 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: protobuf<=3.3.0,>=3.2.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: pyyaml<4.0.0,>=3.12 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: pyvcf<0.7.0,>=0.6.8 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: six<1.11,>=1.9 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: typing<3.7.0,>=3.6.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Requirement already satisfied: futures<4.0.0,>=3.1.1 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==2.3.0.dev0)
Collecting google-apitools<=0.5.11,>=0.5.10 (from apache-beam==2.3.0.dev0)
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:318:
SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension
to TLS is not available on this platform. This may cause the server to present an incorrect
TLS certificate, which can cause validation failures. You can upgrade to a newer version of
Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:122:
InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3
from configuring SSL appropriately and may cause certain SSL connections to fail. You can
upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Using cached google_apitools-0.5.11-py2-none-any.whl
Collecting proto-google-cloud-datastore-v1<=0.90.4,>=0.90.0 (from apache-beam==2.3.0.dev0)
Collecting googledatastore==7.0.1 (from apache-beam==2.3.0.dev0)
Collecting google-cloud-pubsub==0.26.0 (from apache-beam==2.3.0.dev0)
  Using cached google_cloud_pubsub-0.26.0-py2.py3-none-any.whl
Collecting google-cloud-bigquery==0.25.0 (from apache-beam==2.3.0.dev0)
  Using cached google_cloud_bigquery-0.25.0-py2.py3-none-any.whl
Collecting pyhamcrest<2.0,>=1.9 (from apache-beam==2.3.0.dev0)
  Using cached PyHamcrest-1.9.0-py2.py3-none-any.whl
Requirement already satisfied: enum34>=1.0.4 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from grpcio<2.0,>=1.0->apache-beam==2.3.0.dev0)
Requirement already satisfied: pbr>=0.11 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: rsa>=3.1.4 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1-modules>=0.0.5 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: pyasn1>=0.1.7 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client<4.0.0,>=2.0.1->apache-beam==2.3.0.dev0)
Requirement already satisfied: setuptools in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from protobuf<=3.3.0,>=3.2.0->apache-beam==2.3.0.dev0)
Collecting googleapis-common-protos<2.0dev,>=1.5.2 (from proto-google-cloud-datastore-v1<=0.90.4,>=0.90.0->apache-beam==2.3.0.dev0)
Collecting google-cloud-core<0.26dev,>=0.25.0 (from google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached google_cloud_core-0.25.0-py2.py3-none-any.whl
Collecting gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0 (from google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
Collecting google-auth<2.0.0dev,>=0.4.0 (from google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached google_auth-1.2.1-py2.py3-none-any.whl
Collecting google-auth-httplib2 (from google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached google_auth_httplib2-0.0.3-py2.py3-none-any.whl
Collecting grpc-google-iam-v1<0.12dev,>=0.11.1 (from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
Collecting google-gax<0.16dev,>=0.15.7 (from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached google_gax-0.15.16-py2.py3-none-any.whl
Collecting proto-google-cloud-pubsub-v1[grpc]<0.16dev,>=0.15.4 (from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
Collecting cachetools>=2.0.0 (from google-auth<2.0.0dev,>=0.4.0->google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached cachetools-2.0.1-py2.py3-none-any.whl
Collecting future<0.17dev,>=0.16.0 (from google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
Collecting requests<3.0dev,>=2.13.0 (from google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached requests-2.18.4-py2.py3-none-any.whl
Collecting ply==3.8 (from google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
Collecting certifi>=2017.4.17 (from requests<3.0dev,>=2.13.0->google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached certifi-2017.11.5-py2.py3-none-any.whl
Collecting chardet<3.1.0,>=3.0.2 (from requests<3.0dev,>=2.13.0->google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached chardet-3.0.4-py2.py3-none-any.whl
Collecting urllib3<1.23,>=1.21.1 (from requests<3.0dev,>=2.13.0->google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached urllib3-1.22-py2.py3-none-any.whl
Collecting idna<2.7,>=2.5 (from requests<3.0dev,>=2.13.0->google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.3.0.dev0)
  Using cached idna-2.6-py2.py3-none-any.whl
Installing collected packages: google-apitools, googleapis-common-protos, proto-google-cloud-datastore-v1,
googledatastore, cachetools, google-auth, google-auth-httplib2, google-cloud-core, grpc-google-iam-v1,
future, certifi, chardet, urllib3, idna, requests, ply, google-gax, proto-google-cloud-pubsub-v1,
gapic-google-cloud-pubsub-v1, google-cloud-pubsub, google-cloud-bigquery, pyhamcrest, apache-beam
  Found existing installation: apache-beam 2.3.0.dev0
    Uninstalling apache-beam-2.3.0.dev0:
      Successfully uninstalled apache-beam-2.3.0.dev0
  Running setup.py develop for apache-beam
Successfully installed apache-beam cachetools-2.0.1 certifi-2017.11.5 chardet-3.0.4 future-0.16.0
gapic-google-cloud-pubsub-v1-0.15.4 google-apitools-0.5.11 google-auth-1.2.1 google-auth-httplib2-0.0.3
google-cloud-bigquery-0.25.0 google-cloud-core-0.25.0 google-cloud-pubsub-0.26.0 google-gax-0.15.16
googleapis-common-protos-1.5.3 googledatastore-7.0.1 grpc-google-iam-v1-0.11.4 idna-2.6 ply-3.8
proto-google-cloud-datastore-v1-0.90.4 proto-google-cloud-pubsub-v1-0.15.4 pyhamcrest-1.9.0
requests-2.18.4 urllib3-1.22
py27gcp runtests: commands[1] | python --version
Python 2.7.6
py27gcp runtests: commands[2] | - find apache_beam -type f -name *.pyc -delete
py27gcp runtests: commands[3] | python apache_beam/examples/complete/autocomplete_test.py
Traceback (most recent call last):
  File "apache_beam/examples/complete/autocomplete_test.py", line 22, in <module>
    import apache_beam as beam
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/__init__.py",>
line 86, in <module>
    from apache_beam import coders
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/coders/__init__.py",>
line 18, in <module>
    from apache_beam.coders.coders import *
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/coders/coders.py",>
line 30, in <module>
    from apache_beam.portability.api import beam_runner_api_pb2
  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/apache_beam/portability/api/beam_runner_api_pb2.py",>
line 313, in <module>
    options=None, file=DESCRIPTOR),
TypeError: __new__() got an unexpected keyword argument 'file'
ERROR: InvocationError: '<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/src/sdks/python/target/.tox/py27gcp/bin/python>
apache_beam/examples/complete/autocomplete_test.py'
___________________________________ summary ____________________________________
ERROR:   docs: commands failed
  lint: commands succeeded
ERROR:   py27: commands failed
ERROR:   py27cython: commands failed
ERROR:   py27gcp: commands failed
Build step 'Execute shell' marked build as failure
Not sending mail to unregistered user github@nakomis.com
Not sending mail to unregistered user herohde@google.com
Not sending mail to unregistered user mariagh@google.com

Mime
View raw message