beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From al...@apache.org
Subject [beam] 01/01: Merge pull request #4302 from udim/docs
Date Fri, 22 Dec 2017 17:50:56 GMT
This is an automated email from the ASF dual-hosted git repository.

altay pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/beam.git

commit 28c92e4d27003810427c84e56df61785219ce799
Merge: 151ae67 f3c498b
Author: Ahmet Altay <aaltay@gmail.com>
AuthorDate: Fri Dec 22 09:50:52 2017 -0800

    Merge pull request #4302 from udim/docs
    
    Enable multiprocess docs generation

 sdks/python/generate_pydoc.sh | 6 +++---
 sdks/python/setup.py          | 6 ++----
 sdks/python/tox.ini           | 2 +-
 3 files changed, 6 insertions(+), 8 deletions(-)

diff --cc sdks/python/setup.py
index 26b4689,7c91c6e..15ec37f
--- a/sdks/python/setup.py
+++ b/sdks/python/setup.py
@@@ -102,16 -102,12 +102,14 @@@ REQUIRED_PACKAGES = 
      'httplib2>=0.8,<0.10',
      'mock>=1.0.1,<3.0.0',
      'oauth2client>=2.0.1,<4.0.0',
 -    'protobuf>=3.2.0,<4',
 +    # grpcio 1.8.1 and above requires protobuf 3.5.0.post1.
 +    'protobuf>=3.5.0.post1,<4',
      'pyyaml>=3.12,<4.0.0',
      'pyvcf>=0.6.8,<0.7.0',
-     # Six 1.11.0 incompatible with apitools.
-     # TODO(BEAM-2964): Remove the upper bound.
-     'six>=1.9,<1.11',
+     'six>=1.9,<1.12',
      'typing>=3.6.0,<3.7.0',
      'futures>=3.1.1,<4.0.0',
 +    'hdfs3>=0.3.0,<0.4.0',
      ]
  
  REQUIRED_SETUP_PACKAGES = [

-- 
To stop receiving notification emails like this one, please contact
"commits@beam.apache.org" <commits@beam.apache.org>.

Mime
View raw message