beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From al...@apache.org
Subject [beam] branch master updated: Remove redundant six dependency
Date Thu, 07 Dec 2017 08:12:22 GMT
This is an automated email from the ASF dual-hosted git repository.

altay pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/beam.git


The following commit(s) were added to refs/heads/master by this push:
     new 1a8c268  Remove redundant six dependency
1a8c268 is described below

commit 1a8c268893fe3ac79ebaccf4f5a89b0fdb1102db
Author: Ahmet Altay <aaltay@gmail.com>
AuthorDate: Thu Dec 7 00:12:19 2017 -0800

    Remove redundant six dependency
    
    The same dependency is already in the `REQUIRED_PACKAGES` section. Do we need this separately?
---
 sdks/python/setup.py | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/sdks/python/setup.py b/sdks/python/setup.py
index e83a490..b1ec92f 100644
--- a/sdks/python/setup.py
+++ b/sdks/python/setup.py
@@ -118,10 +118,6 @@ REQUIRED_SETUP_PACKAGES = [
 
 REQUIRED_TEST_PACKAGES = [
     'pyhamcrest>=1.9,<2.0',
-    # Six required by nose plugins management.
-    # Six 1.11.0 incompatible with apitools.
-    # TODO(BEAM-2964): Remove the upper bound.
-    'six>=1.9,<1.11',
     ]
 
 GCP_REQUIREMENTS = [

-- 
To stop receiving notification emails like this one, please contact
['"commits@beam.apache.org" <commits@beam.apache.org>'].

Mime
View raw message