beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xu Mingmin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-3110) The transform Read(UnboundedKafkaSource) is currently not supported
Date Thu, 09 Nov 2017 00:02:00 GMT

    [ https://issues.apache.org/jira/browse/BEAM-3110?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16244960#comment-16244960
] 

Xu Mingmin commented on BEAM-3110:
----------------------------------

seems the bug is not there in latest master branch, will do more test to verify.

> The transform Read(UnboundedKafkaSource) is currently not supported
> -------------------------------------------------------------------
>
>                 Key: BEAM-3110
>                 URL: https://issues.apache.org/jira/browse/BEAM-3110
>             Project: Beam
>          Issue Type: Bug
>          Components: runner-flink
>    Affects Versions: 2.2.0, 2.3.0
>            Reporter: Xu Mingmin
>            Assignee: Aljoscha Krettek
>
> I see this issue when submitting a job to Flink cluster. It appears after build {{2.2.0-20170912.083349-51}}.
> {code}
> org.apache.flink.client.program.ProgramInvocationException: The main method caused an
error.
> 	at org.apache.flink.client.program.PackagedProgram.callMainMethod(PackagedProgram.java:545)
> 	at org.apache.flink.client.program.PackagedProgram.invokeInteractiveModeForExecution(PackagedProgram.java:419)
> 	at org.apache.flink.client.program.ClusterClient.run(ClusterClient.java:381)
> 	at org.apache.flink.client.CliFrontend.executeProgram(CliFrontend.java:838)
> 	at org.apache.flink.client.CliFrontend.run(CliFrontend.java:259)
> 	at org.apache.flink.client.CliFrontend.parseParameters(CliFrontend.java:1086)
> 	at org.apache.flink.client.CliFrontend$2.call(CliFrontend.java:1133)
> 	at org.apache.flink.client.CliFrontend$2.call(CliFrontend.java:1130)
> 	at org.apache.flink.runtime.security.HadoopSecurityContext$1.run(HadoopSecurityContext.java:43)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at javax.security.auth.Subject.doAs(Subject.java:415)
> 	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1657)
> 	at org.apache.flink.runtime.security.HadoopSecurityContext.runSecured(HadoopSecurityContext.java:40)
> 	at org.apache.flink.client.CliFrontend.main(CliFrontend.java:1129)
> Caused by: java.lang.UnsupportedOperationException: The transform Read(UnboundedKafkaSource)
is currently not supported.
> 	at org.apache.beam.runners.flink.FlinkStreamingPipelineTranslator.visitPrimitiveTransform(FlinkStreamingPipelineTranslator.java:113)
> 	at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:666)
> 	at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:658)
> 	at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:658)
> 	at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:658)
> 	at org.apache.beam.sdk.runners.TransformHierarchy$Node.access$600(TransformHierarchy.java:311)
> 	at org.apache.beam.sdk.runners.TransformHierarchy.visit(TransformHierarchy.java:245)
> 	at org.apache.beam.sdk.Pipeline.traverseTopologically(Pipeline.java:451)
> 	at org.apache.beam.runners.flink.FlinkPipelineTranslator.translate(FlinkPipelineTranslator.java:38)
> 	at org.apache.beam.runners.flink.FlinkStreamingPipelineTranslator.translate(FlinkStreamingPipelineTranslator.java:69)
> 	at org.apache.beam.runners.flink.FlinkPipelineExecutionEnvironment.translate(FlinkPipelineExecutionEnvironment.java:104)
> 	at org.apache.beam.runners.flink.FlinkRunner.run(FlinkRunner.java:113)
> 	at org.apache.beam.sdk.Pipeline.run(Pipeline.java:304)
> 	at org.apache.beam.sdk.Pipeline.run(Pipeline.java:290)
> {code} 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message