beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aljoscha Krettek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-3043) Set user-specified Transform names on Flink operations
Date Wed, 11 Oct 2017 14:30:00 GMT

    [ https://issues.apache.org/jira/browse/BEAM-3043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16200366#comment-16200366
] 

Aljoscha Krettek commented on BEAM-3043:
----------------------------------------

Proper unique names are important, for example to make Metrics work correctly.

> Set user-specified Transform names on Flink operations
> ------------------------------------------------------
>
>                 Key: BEAM-3043
>                 URL: https://issues.apache.org/jira/browse/BEAM-3043
>             Project: Beam
>          Issue Type: Improvement
>          Components: runner-flink
>            Reporter: Aljoscha Krettek
>            Assignee: Aljoscha Krettek
>
> Currently, we don't always set a name on the generated operations or we set the wrong
name. For example, in the batch translation we set the result of {{PTransform.getName()}}
as the name, which is only the name of the {{PTransform}} itself, not the name that the user
specified when creating a Pipeline.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message