beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Cwik (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (BEAM-2959) Fix proto enums to not use 0
Date Fri, 15 Sep 2017 18:25:00 GMT

     [ https://issues.apache.org/jira/browse/BEAM-2959?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luke Cwik updated BEAM-2959:
----------------------------
    Description: Proto3 uses 0 as the default value for enums and does not encode it on the
wire which means that you can not detect the difference between a value that is unset and
an enum that is set but has a value of zero.  (was: Proto3 uses 0 as the default value for
enums and does not encode it on the wire which means that you can not detect the difference
between a value that is unset and an enum that is set.)

> Fix proto enums to not use 0
> ----------------------------
>
>                 Key: BEAM-2959
>                 URL: https://issues.apache.org/jira/browse/BEAM-2959
>             Project: Beam
>          Issue Type: Bug
>          Components: beam-model
>            Reporter: Luke Cwik
>            Assignee: Luke Cwik
>            Priority: Minor
>
> Proto3 uses 0 as the default value for enums and does not encode it on the wire which
means that you can not detect the difference between a value that is unset and an enum that
is set but has a value of zero.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message