beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PerformanceTests_JDBC #209
Date Wed, 20 Sep 2017 04:35:27 GMT
See <https://builds.apache.org/job/beam_PerformanceTests_JDBC/209/display/redirect?page=changes>

Changes:

[chamikara] Updates.

------------------------------------------
GitHub pull request #3668 of commit 8adb779ec7f8b3726928ae3a7ead86bd429bc8bb, no merge conflicts.
Setting status of 8adb779ec7f8b3726928ae3a7ead86bd429bc8bb to PENDING with url https://builds.apache.org/job/beam_PerformanceTests_JDBC/209/
and message: 'Build started sha1 is merged.'
Using context: Jenkins: JDBC Performance Test
[EnvInject] - Loading node environment variables.
Building remotely on beam1 (beam) in workspace <https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://github.com/apache/beam.git # timeout=10
Fetching upstream changes from https://github.com/apache/beam.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/apache/beam.git +refs/heads/*:refs/remotes/origin/*
+refs/pull/3668/*:refs/remotes/origin/pr/3668/*
 > git rev-parse refs/remotes/origin/pr/3668/merge^{commit} # timeout=10
 > git rev-parse refs/remotes/origin/origin/pr/3668/merge^{commit} # timeout=10
Checking out Revision 2198ab86b66cc731d10511516f0f66c662fd3151 (refs/remotes/origin/pr/3668/merge)
Commit message: "Merge 8adb779ec7f8b3726928ae3a7ead86bd429bc8bb into e8a52827e792c9cbce5832e5edcd0399428c24f3"
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 2198ab86b66cc731d10511516f0f66c662fd3151
 > git rev-list 5e22c97cbaa48ad54c40d3cf091a2d2900d8afbf # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
SPARK_LOCAL_IP=127.0.0.1

[EnvInject] - Variables injected successfully.
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins4743726029780413796.sh
+ rm -rf PerfKitBenchmarker
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins6888028383971305726.sh
+ git clone https://github.com/GoogleCloudPlatform/PerfKitBenchmarker.git
Cloning into 'PerfKitBenchmarker'...
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins3764398704742416428.sh
+ pip install --user -r PerfKitBenchmarker/requirements.txt
Requirement already satisfied (use --upgrade to upgrade): python-gflags==3.1.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 14))
Requirement already satisfied (use --upgrade to upgrade): jinja2>=2.7 in /usr/local/lib/python2.7/dist-packages
(from -r PerfKitBenchmarker/requirements.txt (line 15))
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python2.7/dist-packages
(from -r PerfKitBenchmarker/requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): colorlog[windows]==2.6.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 17))
  Installing extra requirements: 'windows'
Requirement already satisfied (use --upgrade to upgrade): blinker>=1.3 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): futures>=3.0.3 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.12 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): pint>=0.7 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 21))
Requirement already satisfied (use --upgrade to upgrade): numpy in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): functools32 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): contextlib2>=0.5.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 24))
Cleaning up...
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins7144182252056535729.sh
+ pip install --user -e 'sdks/python/[gcp,test]'
Obtaining file://<https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python>
  Running setup.py (path:<https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python/setup.py)>
egg_info for package from file://<https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python>
    <https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python/setup.py>:66:
UserWarning: You are using version 1.5.4 of pip. However, version 7.0.0 is recommended.
      _PIP_VERSION, REQUIRED_PIP_VERSION
    no previously-included directories found matching 'doc/.build'
    
    Installed <https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python/nose-1.3.7-py2.7.egg>
    
    warning: no files found matching 'README.md'
    warning: no files found matching 'NOTICE'
    warning: no files found matching 'LICENSE'
  Installing extra requirements: 'gcp,test'
Requirement already satisfied (use --upgrade to upgrade): avro>=1.8.1,<2.0.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): crcmod>=1.7,<2.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): dill==0.2.6 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): grpcio>=1.0,<2.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): httplib2>=0.8,<0.10 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): mock>=1.0.1,<3.0.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): oauth2client>=2.0.1,<4.0.0
in /home/jenkins/.local/lib/python2.7/site-packages (from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): protobuf>=3.2.0,<=3.3.0 in
/home/jenkins/.local/lib/python2.7/site-packages (from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyyaml>=3.12,<4.0.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): typing>=3.6.0,<3.7.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyhamcrest>=1.9,<2.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): six>=1.9,<1.11 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): google-apitools>=0.5.10,<=0.5.11
in /home/jenkins/.local/lib/python2.7/site-packages (from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): proto-google-cloud-datastore-v1>=0.90.0,<=0.90.4
in /home/jenkins/.local/lib/python2.7/site-packages (from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): googledatastore==7.0.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): google-cloud-pubsub==0.26.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): google-cloud-bigquery==0.25.0 in
/home/jenkins/.local/lib/python2.7/site-packages (from apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): futures>=2.2.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from grpcio>=1.0,<2.0->apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): enum34>=1.0.4 in /home/jenkins/.local/lib/python2.7/site-packages
(from grpcio>=1.0,<2.0->apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyasn1>=0.1.7 in /home/jenkins/.local/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyasn1-modules>=0.0.5 in /home/jenkins/.local/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): rsa>=3.1.4 in /home/jenkins/.local/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python2.7/dist-packages
(from protobuf>=3.2.0,<=3.3.0->apache-beam==2.2.0.dev)
Requirement already satisfied (use --upgrade to upgrade): googleapis-common-protos>=1.5.2,<2.0dev
in /home/jenkins/.local/lib/python2.7/site-packages (from proto-google-cloud-datastore-v1>=0.90.0,<=0.90.4->apache-beam==2.2.0.dev)
Installing collected packages: apache-beam
  Running setup.py develop for apache-beam
    <https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python/setup.py>:66:
UserWarning: You are using version 1.5.4 of pip. However, version 7.0.0 is recommended.
      _PIP_VERSION, REQUIRED_PIP_VERSION
    
    warning: no files found matching 'README.md'
    warning: no files found matching 'NOTICE'
    warning: no files found matching 'LICENSE'
    Creating /home/jenkins/.local/lib/python2.7/site-packages/apache-beam.egg-link (link to
.)
    apache-beam 2.2.0.dev is already the active version in easy-install.pth
    
    Installed <https://builds.apache.org/job/beam_PerformanceTests_JDBC/ws/sdks/python>
Successfully installed apache-beam
Cleaning up...
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins3485651518291988736.sh
+ echo xyz123
xyz123
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins3179629303683294909.sh
+ ls /home/jenkins/
bin
env.sh
jenkins-slave
tmp
tools
tools.bak
[beam_PerformanceTests_JDBC] $ /bin/bash -xe /tmp/jenkins6263850929125921111.sh
+ ls /home/jenkins/.kube/
ls: cannot access /home/jenkins/.kube/: No such file or directory
Build step 'Execute shell' marked build as failure

Mime
View raw message