beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xu Mingmin (JIRA)" <>
Subject [jira] [Updated] (BEAM-2798) rename simpleQuery to query and query to queryMulti
Date Thu, 24 Aug 2017 00:30:01 GMT


Xu Mingmin updated BEAM-2798:
    Issue Type: Sub-task  (was: Improvement)
        Parent: BEAM-2679

> rename simpleQuery to query and query to queryMulti
> ---------------------------------------------------
>                 Key: BEAM-2798
>                 URL:
>             Project: Beam
>          Issue Type: Sub-task
>          Components: dsl-sql
>            Reporter: Xu Mingmin
>              Labels: dsl_sql_merge, dsl_sql_review
> One other question from playing around with things more: simpleQuery vs query method
names. Would it be better if they were named query and queryMulti, respectively? Two potential
reasons why that might be better: 1) make simple things simple, e.g., the single input version
should be simpler to express. 2) method names typically should be actions/verbs, but simpleQuery
makes it sound like a noun/object.

This message was sent by Atlassian JIRA

View raw message