beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ahmet Altay (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-1969) GCP extras should not required fix version of proto-google-cloud-datastore-v1
Date Wed, 12 Jul 2017 16:07:00 GMT

    [ https://issues.apache.org/jira/browse/BEAM-1969?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16084227#comment-16084227
] 

Ahmet Altay commented on BEAM-1969:
-----------------------------------

[~MarcBoissonneault] missed this earlier. For dependencies, in general we pin version. This
prevents breakages in the released version due to a breaking change in a dependency. With
each release, we expand this range with newer version as we test and verify that at the release
time newer versions are compatible and tested.

> GCP extras should not required fix version of proto-google-cloud-datastore-v1
> -----------------------------------------------------------------------------
>
>                 Key: BEAM-1969
>                 URL: https://issues.apache.org/jira/browse/BEAM-1969
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py
>    Affects Versions: 0.6.0
>            Reporter: Marc Boissonneault
>            Assignee: Ahmet Altay
>            Priority: Minor
>             Fix For: 2.0.0
>
>
> When installing apache beam with to following command:
> {code}
> pip install apache-beam[gcp]==0.6.0
> {code}
> The *proto-google-cloud-datastore-v1* dependency gets installed with the fix version
*0.90.0.*
> _see [here|https://github.com/apache/beam/blob/master/sdks/python/setup.py#L106]_
> This should not be a fix version requirement.
> For example if I want to use the latest version of the [google-cloud|https://pypi.python.org/pypi/google-cloud]
in the same service, then it requires
>  - google-cloud-datastore >= 1.0.0 
> -- Which depends on gapic-google-cloud-datastore-v1<0.16dev,>=0.15.0 
> --- +Depends on proto-google-cloud-datastore-v1\[grpc\]<0.91dev,>=*0.90.3*+
> Issue priority is not high since we have a workaround to request gapic-proto-google-cloud-datastore-v1>=0.90.3



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message