beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (BEAM-2495) Python IT test fails if six<1.9
Date Wed, 21 Jun 2017 21:41:00 GMT


ASF GitHub Bot commented on BEAM-2495:

GitHub user markflyhigh opened a pull request:

    [BEAM-2495] Add Python test dependency six>=1.9

    Be sure to do all of the following to help us incorporate your contribution
    quickly and easily:
     - [x] Make sure the PR title is formatted like:
       `[BEAM-<Jira issue #>] Description of pull request`
     - [ ] Make sure tests pass via `mvn clean verify`.
     - [x] Replace `<Jira issue #>` in the title with the actual Jira issue
           number, if there is one.
     - [ ] If this contribution is large, please file an Apache
           [Individual Contributor License Agreement](
    It's required by nose plugins management which is used to define customized commandline
argument `--test-pipeline-options` and helps to run python integration test.

You can merge this pull request into a Git repository by running:

    $ git pull update-python-six

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #3416
commit 541f5b2e42076460a11a54b7f29c2bb60c9c8dd6
Author: Mark Liu <>
Date:   2017-06-21T21:28:26Z

    [BEAM-2495] Add Python test dependency six>=1.9


> Python IT test fails if six<1.9
> -------------------------------
>                 Key: BEAM-2495
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py, testing
>            Reporter: Mark Liu
>            Assignee: Mark Liu
> Python uses nose.plugins.0.10 to manage customized commandline argument: --test-pipeline-options
to build test pipeline options and run integration test. nose.plugins.0.10 is required six>=1.9,
otherwise, following error will occur:
> {code}
> /tmp/perfkitbenchmarker/runs/985bc121/beam/sdks/python/nose-1.3.7-py2.7.egg/nose/plugins/
RuntimeWarning: Unable to load plugin beam_test_plugin = test_config:BeamTestPlugin: (six
1.5.2 (/usr/lib/python2.7/dist-packages), Requirement.parse('six>=1.9'))
>   RuntimeWarning)
> usage: [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
>    or: --help [cmd1 cmd2 ...]
>    or: --help-commands
>    or: cmd --help
> error: option --test-pipeline-options not recognized
> {code}
> I think we should add this dependency to REQUIRED_TEST_PACKAGES in

This message was sent by Atlassian JIRA

View raw message