beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenneth Knowles (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (BEAM-2375) upgrade beam-version to 2.0.0
Date Tue, 06 Jun 2017 03:36:18 GMT

    [ https://issues.apache.org/jira/browse/BEAM-2375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16038048#comment-16038048
] 

Kenneth Knowles edited comment on BEAM-2375 at 6/6/17 3:35 AM:
---------------------------------------------------------------

The different {{pom.xml}} files on the branch should be altered to use the {{project.version}}
property so that they stay up to date with the project.

Currently the branch _inherits_ from 0.7.0-SNAPSHOT (which was never released because it became
2.0.0) but _depends_ on 0.6.0 of the core SDK.

This can cause trouble with IntelliJ, which will compile according to the spec, but the classpath
will include HEAD of all modules.


was (Author: kenn):
The different {{pom.xml}} files on the branch should be altered to use the {{project.version}}
propery so that they stay up to date with the project.

Currently the branch _inherits_ from 0.7.0-SNAPSHOT (which was never released because it becamse
2.0.0) but _depends_ on 0.6.0 of the core SDK.

This can cause trouble with IntelliJ, which will compile according to the spec, but the classpath
will include HEAD of all modules.

> upgrade beam-version to 2.0.0
> -----------------------------
>
>                 Key: BEAM-2375
>                 URL: https://issues.apache.org/jira/browse/BEAM-2375
>             Project: Beam
>          Issue Type: Bug
>          Components: dsl-sql
>            Reporter: James Xu
>            Assignee: Jean-Baptiste Onofré
>




--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message