beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-2377) Cross compile flink runner to scala 2.11
Date Mon, 29 May 2017 14:31:04 GMT

    [ https://issues.apache.org/jira/browse/BEAM-2377?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16028407#comment-16028407
] 

ASF GitHub Bot commented on BEAM-2377:
--------------------------------------

GitHub user neurolabs opened a pull request:

    https://github.com/apache/beam/pull/3255

    [BEAM-2377] Allow usage of scala 2.11 dependencies as well as cross compilation for flink
runner

    Flink allows being built against scala 2.11. But the Flink Runner did
    not.
    
    This commit alleviates that, as well as allowing for ensuring that
    builds work against scala 2.11 dependencies. It introduces a
    scala.version mvn property that is set to 2.10 as a default, as well as
    a mvn profile that overrides the scala version to 2.11.
    
    I'm not sure about the granularity (should I only enable this for the
    flink runner, or should the whole build be verified against 2.11). So
    please comment on this PR.
    
    It would be nice if you could cross publish the flink runner for
    scala-2.11 based on this pull request.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/neurolabs/beam master

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/beam/pull/3255.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #3255
    
----
commit 3e2564d65fb371abd0caf663785faee4f1f73120
Author: Ole Langbehn <ole.langbehn@inoio.de>
Date:   2017-05-29T14:14:18Z

    Allow usage of scala 2.11 dependencies as well as cross compilation for flink runner
    
    Flink allows being built against scala 2.11. But the Flink Runner did
    not.
    
    This commit alleviates that, as well as allowing for ensuring that
    builds work against scala 2.11 dependencies. It introduces a
    scala.version mvn property that is set to 2.10 as a default, as well as
    a mvn profile that overrides the scala version to 2.11.

----


> Cross compile flink runner to scala 2.11
> ----------------------------------------
>
>                 Key: BEAM-2377
>                 URL: https://issues.apache.org/jira/browse/BEAM-2377
>             Project: Beam
>          Issue Type: Improvement
>          Components: runner-flink
>            Reporter: Ole Langbehn
>            Assignee: Aljoscha Krettek
>
> The flink runner is compiled for flink built against scala 2.10. flink cross compiles
its scala artifacts against 2.10 and 2.11.
> In order to make it possible to use beam with the flink runner in scala 2.11 projects,
it would be nice if you could publish the flink runner for 2.11 next to 2.10.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message