beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-2300) Upgrade python sdk dependencies
Date Mon, 22 May 2017 23:43:04 GMT

    [ https://issues.apache.org/jira/browse/BEAM-2300?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16020412#comment-16020412
] 

ASF GitHub Bot commented on BEAM-2300:
--------------------------------------

GitHub user aaltay opened a pull request:

    https://github.com/apache/beam/pull/3202

    [BEAM-2300] upgrading python sdk dependencies

    R: @charlesccychen 
    
    For pinned dependencies, I switched them to range dependencies as otherwise we would break
backward compatibility.
    
    For range dependencies, I extended the range.
    
    It will be trick to test all these ranges with all combinations of dependencies and ensure
that things are in working order.
    
    cc: @sb2nov @markflyhigh for ideas.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/aaltay/beam verd

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/beam/pull/3202.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #3202
    
----
commit ade0e1a119cc83af0363f85f1ade4a94d1ff5597
Author: Ahmet Altay <altay@google.com>
Date:   2017-05-22T23:40:09Z

    upgrading python sdk dependencies

----


> Upgrade python sdk dependencies
> -------------------------------
>
>                 Key: BEAM-2300
>                 URL: https://issues.apache.org/jira/browse/BEAM-2300
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py
>            Reporter: Ahmet Altay
>             Fix For: 2.1.0
>
>
> cc: [~charleschen]
> Upgraded python sdk dependencies if possible:
> Some opportunities:
> protobuf 3.3.0
> proto-google-cloud-datastore-v1 0.90.4
> google-apitools 0.5.11
> google-cloud-bigquery 0.24.0



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message