beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenneth Knowles (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BEAM-2268) NullPointerException in com.datatorrent.netlet.util.Slice via ApexStateInternals
Date Thu, 11 May 2017 22:44:04 GMT
Kenneth Knowles created BEAM-2268:
-------------------------------------

             Summary: NullPointerException in com.datatorrent.netlet.util.Slice via ApexStateInternals
                 Key: BEAM-2268
                 URL: https://issues.apache.org/jira/browse/BEAM-2268
             Project: Beam
          Issue Type: Bug
          Components: runner-apex
            Reporter: Kenneth Knowles
            Assignee: Thomas Weise


I've browsed the code, and this is a certain NPE in netlet 1.2.1 but our dependencies are
on 1.3.0.

I have read over the dependency tree (both our project and generated archetype) and deliberately
added even tighter deps on 1.3.0. I have not managed to force any dependency on 1.2.1, yet
maven clearly logs its download of 1.2.1 and it appears to be running against it.

{code}
java.lang.NullPointerException
	at com.datatorrent.netlet.util.Slice.<init>(Slice.java:54)
	at org.apache.beam.runners.apex.translation.utils.ApexStateInternals$ApexStateInternalsFactory.stateInternalsForKey(ApexStateInternals.java:445)
	at org.apache.beam.runners.apex.translation.utils.ApexStateInternals$ApexStateInternalsFactory.stateInternalsForKey(ApexStateInternals.java:427)
{code}

Jenkins obviously has a different configuration, so that is a place to look next, perhaps.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message