beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Bradshaw (JIRA)" <>
Subject [jira] [Reopened] (BEAM-1327) Replace OutputTimeFn with enum
Date Mon, 01 May 2017 20:26:04 GMT


Robert Bradshaw reopened BEAM-1327:

Python is already using an "enum", but still named OutputTimeFn. We should rename it for consistency.

Python also provides a OUTPUT_AT_EARLIEST_TRANSFORMED option which queries the WindowFn. IIRC,
this was to support sliding windows in a sane way. Should we add this to Java or remove it
from Python? 

> Replace OutputTimeFn with enum
> ------------------------------
>                 Key: BEAM-1327
>                 URL:
>             Project: Beam
>          Issue Type: New Feature
>          Components: sdk-java-core
>            Reporter: Kenneth Knowles
>            Assignee: Kenneth Knowles
>            Priority: Minor
>              Labels: backward-incompatible
>             Fix For: First stable release
> The class {{OutputTimeFn}} is overkill for a Fn API crossing. There are only three sensible
values known: MIN, MAX, EOW. The interface is right for implementing these, but the full class
is left over from the days when there was little cost to shipping new kinds of fns. An enum
is concise.
> This can be done "mostly" backwards compatibly with legacy adapters in place, but might
be less confusing without them.

This message was sent by Atlassian JIRA

View raw message