beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-2093) Update Jackson version to 2.8.8 in archetype (or align with parent pom)
Date Thu, 27 Apr 2017 13:00:07 GMT

    [ https://issues.apache.org/jira/browse/BEAM-2093?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15986563#comment-15986563
] 

ASF GitHub Bot commented on BEAM-2093:
--------------------------------------

GitHub user elek opened a pull request:

    https://github.com/apache/beam/pull/2737

    [BEAM-2093] Use the jackson version from the maven property in maven …

    …archetypes
    
    This pull request enables the filtering for the maven example archetypes. With a separated
delimiter (@) we can separate the build time filtering (@variable@) and archetype runtime
filtering (${...}). With this solution we can always use the right version from the jersey
using the maven properties from the parent pom.
    
    
    --- 
    
    Be sure to do all of the following to help us incorporate your contribution
    quickly and easily:
    
     - [ ] Make sure the PR title is formatted like:
       `[BEAM-<Jira issue #>] Description of pull request`
     - [ ] Make sure tests pass via `mvn clean verify`. (Even better, enable
           Travis-CI on your fork and ensure the whole test matrix passes).
     - [ ] Replace `<Jira issue #>` in the title with the actual Jira issue
           number, if there is one.
     - [ ] If this contribution is large, please file an Apache
           [Individual Contributor License Agreement](https://www.apache.org/licenses/icla.pdf).
    
    ---


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/elek/beam BEAM-2093

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/beam/pull/2737.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2737
    
----
commit 05d627c95febbb8dc4f83d9684571952c78f9778
Author: Elek, Márton <elek@users.noreply.github.com>
Date:   2017-04-27T12:52:05Z

    [BEAM-2093] Use the jackson version from the maven property in maven archetypes

----


> Update Jackson version to 2.8.8 in archetype (or align with parent pom)
> -----------------------------------------------------------------------
>
>                 Key: BEAM-2093
>                 URL: https://issues.apache.org/jira/browse/BEAM-2093
>             Project: Beam
>          Issue Type: Bug
>          Components: project-management
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Elek, Marton
>             Fix For: First stable release
>
>
> The jackson version generated by the latest examples archetype is not compatible with
the latest beam. 
> Even to execute the plain word-count example (generated by the archetype):
> {code}
> mvn compile exec:java -Dexec.mainClass=org.apache.beam.examples.WordCount -Dexec.args="--inputFile=pom.xml
--output=counts --runner=spark" -Pspark-runner
> {code}
> Is failing with: 
> {code}
> 11:58:48.231 [main] INFO  org.apache.spark.SparkContext - Successfully stopped SparkContext
> Exception in thread "main" java.lang.RuntimeException: java.lang.ExceptionInInitializerError
>     at org.apache.beam.runners.spark.SparkPipelineResult.runtimeExceptionFrom(SparkPipelineResult.java:57)
>     at org.apache.beam.runners.spark.SparkPipelineResult.beamExceptionFrom(SparkPipelineResult.java:74)
>     at org.apache.beam.runners.spark.SparkPipelineResult.waitUntilFinish(SparkPipelineResult.java:110)
>     at org.apache.beam.runners.spark.SparkPipelineResult.waitUntilFinish(SparkPipelineResult.java:98)
>     at com.hortonworks.hcube.codestream.AsfStat.main(AsfStat.java:54)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
>     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>     at java.lang.reflect.Method.invoke(Method.java:498)
>     at com.intellij.rt.execution.application.AppMain.main(AppMain.java:147)
> Caused by: java.lang.ExceptionInInitializerError
>     at org.apache.spark.rdd.RDD.withScope(RDD.scala:316)
>     at org.apache.spark.rdd.RDD.mapPartitions(RDD.scala:706)
>     at org.apache.spark.api.java.JavaRDDLike$class.mapPartitionsToPair(JavaRDDLike.scala:194)
>     at org.apache.spark.api.java.AbstractJavaRDDLike.mapPartitionsToPair(JavaRDDLike.scala:46)
>     at org.apache.beam.runners.spark.translation.TransformTranslator$6.evaluate(TransformTranslator.java:356)
>     at org.apache.beam.runners.spark.translation.TransformTranslator$6.evaluate(TransformTranslator.java:340)
>     at org.apache.beam.runners.spark.SparkRunner$Evaluator.doVisitTransform(SparkRunner.java:409)
>     at org.apache.beam.runners.spark.SparkRunner$Evaluator.visitPrimitiveTransform(SparkRunner.java:395)
>     at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:488)
>     at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:483)
>     at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:483)
>     at org.apache.beam.sdk.runners.TransformHierarchy$Node.visit(TransformHierarchy.java:483)
>     at org.apache.beam.sdk.runners.TransformHierarchy$Node.access$400(TransformHierarchy.java:232)
>     at org.apache.beam.sdk.runners.TransformHierarchy.visit(TransformHierarchy.java:207)
>     at org.apache.beam.sdk.Pipeline.traverseTopologically(Pipeline.java:383)
>     at org.apache.beam.runners.spark.SparkRunner$2.run(SparkRunner.java:210)
>     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
>     at java.util.concurrent.FutureTask.run(FutureTask.java:266)
>     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
>     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
>     at java.lang.Thread.run(Thread.java:745)
> Caused by: com.fasterxml.jackson.databind.JsonMappingException: Incompatible Jackson
version: 2.8.8
>     at com.fasterxml.jackson.module.scala.JacksonModule$class.setupModule(JacksonModule.scala:64)
>     at com.fasterxml.jackson.module.scala.DefaultScalaModule.setupModule(DefaultScalaModule.scala:19)
>     at com.fasterxml.jackson.databind.ObjectMapper.registerModule(ObjectMapper.java:745)
>     at org.apache.spark.rdd.RDDOperationScope$.<init>(RDDOperationScope.scala:81)
>     at org.apache.spark.rdd.RDDOperationScope$.<clinit>(RDDOperationScope.scala)
>     ... 21 more
> Add Comment
> {code}
> The longterm solution is to use filtering in the archetype and use the jackson version
maven property.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message