beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Sisk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-1972) HIFIO jdk module fails enforcer when only java 7 is installed on machine
Date Sat, 15 Apr 2017 00:03:41 GMT

    [ https://issues.apache.org/jira/browse/BEAM-1972?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15969696#comment-15969696
] 

Stephen Sisk commented on BEAM-1972:
------------------------------------

cc [~dhalperi@google.com] [~davor] wanted to make sure you were aware of this bug. 

I'm investigating solutions - first thing I'm looking into is using profiles based on java
versions.

Goal I'm working towards is that we have enforcer coverage while in java8, but don't break
java 7.

> HIFIO jdk module fails enforcer when only java 7 is installed on machine
> ------------------------------------------------------------------------
>
>                 Key: BEAM-1972
>                 URL: https://issues.apache.org/jira/browse/BEAM-1972
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-java-extensions
>    Affects Versions: First stable release
>            Reporter: Stephen Sisk
>            Assignee: Stephen Sisk
>
> When running on a machine with only java 7, you cannot do a full compile of the project.

> The error message is:
> [WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
> Detected JDK Version: 1.7.0-121 is not in the allowed range [1.8,).
> The failed module is:
> [INFO] Apache Beam :: SDKs :: Java :: IO :: Hadoop :: jdk1.8-tests FAILURE [ 37.549 s]
> This is likely due to the enforcer rules at https://github.com/apache/beam/blob/master/sdks/java/io/hadoop/jdk1.8-tests/pom.xml#L39
> without this exception to the enforcer rules, it throws errors since the cassandra dependency
in that directory is java 8, so the intent is that enforcer should not error out since this
module. 
> Below are the errors (well, warnings) when run with <version>[1.8,)</version>
is commented out: 
> WARNING] /home/sisk/beam/sdks/java/io/hadoop/jdk1.8-tests/src/test/java/org/apache/beam/sdk/io/hadoop/inputformat/HIFIOWithEmbeddedCassandraTest.java:
/home/sisk/.m2/repository/org/apache/cassandra/cassandra-all/3.9/cassandra-all-3.9.jar(org/apache/cassandra/service/EmbeddedCassandraService.class):
major version 52 is newer than 51, the highest major version supported by this compiler.
>   It is recommended that the compiler be upgraded.
> [WARNING] /home/sisk/beam/sdks/java/io/hadoop/jdk1.8-tests/src/test/java/org/apache/beam/sdk/io/hadoop/inputformat/HIFIOWithElasticTest.java:
/home/sisk/.m2/repository/org/elasticsearch/elasticsearch/5.0.0/elasticsearch-5.0.0.jar(org/elasticsearch/action/admin/indices/create/CreateIndexRequest.class):
major version 52 is newer than 51, the highest major version supported by this compiler.
>   It is recommended that the compiler be upgraded.
> [WARNING] /home/sisk/beam/sdks/java/io/hadoop/jdk1.8-tests/src/test/java/org/apache/beam/sdk/io/hadoop/inputformat/HIFIOWithElasticTest.java:
/home/sisk/.m2/repository/org/elasticsearch/elasticsearch/5.0.0/elasticsearch-5.0.0.jar(org/elasticsearch/action/admin/indices/delete/DeleteIndexRequest.class):
major version 52 is newer than 51, the highest major version supported by this compiler.
>   It is recommended that the compiler be upgraded.
> ...and a couple more of these errors.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message