beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Boissonneault (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (BEAM-1954) "test" extra need nose in the requirements list
Date Wed, 12 Apr 2017 20:16:41 GMT

     [ https://issues.apache.org/jira/browse/BEAM-1954?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marc Boissonneault updated BEAM-1954:
-------------------------------------
    Description: 
When installing beam with pip:
{code}
pip install apache-beam[gcp,test]==0.6.0
{code}

And trying to use the TestPipeline:
{code}
from apache_beam.test_pipeline import TestPipeline
{code}

We receive the following error:
{panel}
from nose.plugins.skip import SkipTest
ImportError: No module named nose.plugins.skip
{panel}

Once nose is installed everything works as expected

See: https://github.com/apache/beam/blob/master/sdks/python/setup.py#L100-L102

  was:
When installing beam with pip:
{code}
pip install apache-beam[gcp,test]==0.6.0
{code}

And trying to use the TestPipeline:
{code}
from apache_beam.test_pipeline import TestPipeline
{code}

We receive the following error:
{panel}
from nose.plugins.skip import SkipTest
ImportError: No module named nose.plugins.skip
{panel}

Once nose is installed everything works as expected


> "test" extra need nose in the requirements list
> -----------------------------------------------
>
>                 Key: BEAM-1954
>                 URL: https://issues.apache.org/jira/browse/BEAM-1954
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py
>    Affects Versions: 0.6.0
>            Reporter: Marc Boissonneault
>            Assignee: Ahmet Altay
>            Priority: Minor
>
> When installing beam with pip:
> {code}
> pip install apache-beam[gcp,test]==0.6.0
> {code}
> And trying to use the TestPipeline:
> {code}
> from apache_beam.test_pipeline import TestPipeline
> {code}
> We receive the following error:
> {panel}
> from nose.plugins.skip import SkipTest
> ImportError: No module named nose.plugins.skip
> {panel}
> Once nose is installed everything works as expected
> See: https://github.com/apache/beam/blob/master/sdks/python/setup.py#L100-L102



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message