beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (BEAM-1949) Rename DoFn.Context#sideOutput to #output
Date Thu, 13 Apr 2017 23:59:41 GMT


ASF GitHub Bot commented on BEAM-1949:

GitHub user melap opened a pull request:

    [BEAM-1949] Associated doc changes for renaming sideOutput to output

    Doc changes associated with apache/beam#2512
    This does not change any references to side inputs in Python related comments and past
blog posts. I can change the past blog posts if desired.
    I also split out places that had a single "Side Inputs and Side Outputs" section to separate
sections, "Side Inputs" and "Additional Outputs" so they aren't lumped together anymore.
    R: @tgroh 

You can merge this pull request into a Git repository by running:

    $ git pull outputs

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #212
commit a425683c964895dabfb1a4c13ab50ffc73b15b44
Author: melissa <>
Date:   2017-04-13T22:46:31Z

    [BEAM-1949] Associated doc changes for renaming sideOutput to output


> Rename DoFn.Context#sideOutput to #output
> -----------------------------------------
>                 Key: BEAM-1949
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-java-core
>            Reporter: Thomas Groh
>            Assignee: Thomas Groh
> Having two methods, both named output, one which takes the "main output type" and one
that takes a tag to specify the type more clearly communicates the actual behavior - sideOutput
isn't a "special" way to output, it's the same as output(T), just to a specified PCollection.
This will help pipeline authors understand the actual behavior of outputting to a tag, and
detangle it from "sideInput", which is a special way to receive input. Giving them the same
name means that it's not even strange to call output and provide the main output type, which
is what we want - it's a more specific way to output, but does not have different restrictions
or capabilities.
> This is also a pretty small change within the SDK - it touches about 20 files, and the
changes are pretty automatic.

This message was sent by Atlassian JIRA

View raw message