beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eugene Kirpichov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-1910) test_using_slow_impl very flaky locally
Date Tue, 18 Apr 2017 22:51:41 GMT

    [ https://issues.apache.org/jira/browse/BEAM-1910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15973669#comment-15973669
] 

Eugene Kirpichov commented on BEAM-1910:
----------------------------------------

Vikas, any updates? This is heavily interfering with the ability to run mvn verify locally.

> test_using_slow_impl very flaky locally
> ---------------------------------------
>
>                 Key: BEAM-1910
>                 URL: https://issues.apache.org/jira/browse/BEAM-1910
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py
>            Reporter: Eugene Kirpichov
>            Assignee: Ahmet Altay
>
> Most times this test fails on my machine when running:
> mvn verify -am -T 1C
> test_using_slow_impl (apache_beam.coders.slow_coders_test.SlowCoders) ... FAIL
> ...
> ___________________________________ summary ____________________________________
> ERROR:   docs: commands failed
>   lint: commands succeeded
> ERROR:   py27: commands failed
>   py27cython: commands succeeded
>   py27gcp: commands succeeded
> [ERROR] Command execution failed.
> org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value:
1)
> 	at org.apache.commons.exec.DefaultExecutor.executeInternal(DefaultExecutor.java:404)
> 	at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:166)
> 	at org.codehaus.mojo.exec.ExecMojo.executeCommandLine(ExecMojo.java:764)
> 	at org.codehaus.mojo.exec.ExecMojo.executeCommandLine(ExecMojo.java:711)
> 	at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:289)
> 	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
> 	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
> 	at org.apache.maven.lifecycle.internal.builder.multithreaded.MultiThreadedBuilder$1.call(MultiThreadedBuilder.java:185)
> 	at org.apache.maven.lifecycle.internal.builder.multithreaded.MultiThreadedBuilder$1.call(MultiThreadedBuilder.java:181)
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> 	at java.lang.Thread.run(Thread.java:745)
> Unfortunately the test doesn't print anything to maven output, so I don't know what went
wrong. I also don't know how to rerun the individual test myself.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message