beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (BEAM-1897) Remove Sink
Date Thu, 06 Apr 2017 00:43:41 GMT


ASF GitHub Bot commented on BEAM-1897:

GitHub user reuvenlax opened a pull request:

    [BEAM-1897] Remove Sink in favor of FileBasedSink

    The Sink base class has turned out to be mostly useful for file sinks. Remove Sink, and
replace it with FileBasedSink.
    R: @kennknowles 

You can merge this pull request into a Git repository by running:

    $ git pull streaming_gcs_output

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2447
commit 5cd1630bc938f64003ab6b6b59b16e95d11d078a
Author: Reuven Lax <>
Date:   2017-04-05T19:13:44Z

    Start the process of getting rid of Sink.

commit d148b0e1a02413d55f73e0a42a4f8be6bf059e80
Author: Reuven Lax <>
Date:   2017-04-05T22:06:14Z

    Remove Sink class, and rename Write to WriteFiles.

commit 0af0e60c416718839be157ee88626453cefc5d81
Author: Reuven Lax <>
Date:   2017-04-06T00:22:15Z

    Get rid of Sink and initialize. We keep standin versions of the old Write and Sink transforms
around as a stopgap solution for HDFSFileSink.

commit c2f374342234c71fc132e7eee1dabd8ef55a9794
Author: Reuven Lax <>
Date:   2017-04-06T00:36:43Z

    Roll back IntelliJ's spurious renaming of all "Write" strings and comments to "WriteFiles"

commit 5a37b614699df730040992f300e98fc0910e2f29
Author: Reuven Lax <>
Date:   2017-04-06T00:39:18Z

    Fix a few more spurious renames.


> Remove Sink
> -----------
>                 Key: BEAM-1897
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-java-core
>            Reporter: Reuven Lax
>            Assignee: Davor Bonaci
> Sink is really only used for file sinks. We should remove the abstract base class, and
just keep around FileBasedSink for file sinks.

This message was sent by Atlassian JIRA

View raw message