beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (BEAM-1864) Shorten combining state names: "CombiningValue" and "AccumulatorCombiningState" to Combining (as appropriate)
Date Mon, 03 Apr 2017 20:04:41 GMT


ASF GitHub Bot commented on BEAM-1864:

GitHub user kennknowles opened a pull request:

    [BEAM-1864] Rename CombiningState and friends to be more user-friendly

    Be sure to do all of the following to help us incorporate your contribution
    quickly and easily:
     - [ ] Make sure the PR title is formatted like:
       `[BEAM-<Jira issue #>] Description of pull request`
     - [ ] Make sure tests pass via `mvn clean verify`. (Even better, enable
           Travis-CI on your fork and ensure the whole test matrix passes).
     - [ ] Replace `<Jira issue #>` in the title with the actual Jira issue
           number, if there is one.
     - [ ] If this contribution is large, please file an Apache
           [Individual Contributor License Agreement](

You can merge this pull request into a Git repository by running:

    $ git pull combining-state

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2413
commit d723ccfce33a5ae2969e44ad20692c152c54ce78
Author: Kenneth Knowles <>
Date:   2017-04-03T18:26:30Z

    Rename CombiningState to GroupingState

commit 1aeb69d04a42d9e7d37c65f3c7db9ab33cf5dfd0
Author: Kenneth Knowles <>
Date:   2017-04-03T18:27:26Z

    Rename AccumulatorCombiningState to CombiningState

commit a272ef908dc8c123894949f85bf041b34096482b
Author: Kenneth Knowles <>
Date:   2017-04-03T18:37:50Z

    Rename combiningValue to combining in StateSpecs


> Shorten combining state names: "CombiningValue" and "AccumulatorCombiningState" to Combining
(as appropriate)
> -------------------------------------------------------------------------------------------------------------
>                 Key: BEAM-1864
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-java-core
>            Reporter: Kenneth Knowles
>            Assignee: Kenneth Knowles
>             Fix For: First stable release
> This will clean up potential confusion around different kinds of state, making it very
clear which type is actually analogous to the {{Combine}} transform and takes a {{CombineFn}}.

This message was sent by Atlassian JIRA

View raw message