beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chamikara Jayalath (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-1272) Align the naming of "generateInitialSplits" and "splitIntoBundles" to better reflect their intention
Date Tue, 18 Apr 2017 21:54:41 GMT

    [ https://issues.apache.org/jira/browse/BEAM-1272?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15973588#comment-15973588
] 

Chamikara Jayalath commented on BEAM-1272:
------------------------------------------

Corresponding method in Python SDK BoundedSource is already named split(): https://github.com/apache/beam/blob/master/sdks/python/apache_beam/io/iobase.py#L119

And Python SDK does not have an UnboundedSource.

So I think we're good :)

> Align the naming of "generateInitialSplits" and "splitIntoBundles" to better reflect
their intention
> ----------------------------------------------------------------------------------------------------
>
>                 Key: BEAM-1272
>                 URL: https://issues.apache.org/jira/browse/BEAM-1272
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-java-core
>            Reporter: Stas Levin
>            Assignee: Etienne Chauchot
>            Priority: Minor
>             Fix For: First stable release
>
>
> See [dev list thread|https://lists.apache.org/thread.html/ac5717566707153e85da880cc75c8d047e1c6606861777670bb9107c@%3Cdev.beam.apache.org%3E].



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message