beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Baetens (JIRA)" <>
Subject [jira] [Commented] (BEAM-842) package not found when running on Windows
Date Tue, 18 Apr 2017 20:04:41 GMT


Matthias Baetens commented on BEAM-842:

[vectorijk], [~altay] sorry for the late reply, lost track of this. The problem was solved
soon after I ran into it. Shall I close the issue?

> package not found when running on Windows
> --------------------------------------------------------
>                 Key: BEAM-842
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py
>         Environment: Windows 10, Python 2.7.11
>            Reporter: Matthias Baetens
>            Priority: Minor
>              Labels: newbie
> When having splitting your pipeline into multiple files and configuring your project
according to the Juliaset example (,
the Pipeline still crashes when using Windows.
> This is caused by setuptools defaulting to a .zip on Windows, and the current Beam code
looks for a .tar.gz (, line 400). When changing this line to: output_files =
glob.glob(os.path.join(temp_dir, '*.zip')), it works. 
> Suggestion: checking the OS would probably solve this issue. 

This message was sent by Atlassian JIRA

View raw message