beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenneth Knowles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-1418) MapElements and FlatMapElements should comply with PTransform style guide
Date Thu, 09 Mar 2017 19:30:38 GMT

    [ https://issues.apache.org/jira/browse/BEAM-1418?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15903697#comment-15903697
] 

Kenneth Knowles commented on BEAM-1418:
---------------------------------------

I don't know that it allows getting rid of the intermediate class, just renaming it to {{MissingFunction}}.
FWIW I don't find it awkward :-)

But if the style guide is to just use one class with nullables and do validation at {{expand}}
time you can make that change any time and allow any order of arguments, yes?

> MapElements and FlatMapElements should comply with PTransform style guide
> -------------------------------------------------------------------------
>
>                 Key: BEAM-1418
>                 URL: https://issues.apache.org/jira/browse/BEAM-1418
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-java-core
>            Reporter: Eugene Kirpichov
>            Assignee: Davor Bonaci
>              Labels: backward-incompatible, starter
>             Fix For: First stable release
>
>
> Type structure of these classes can be improved by slightly changing the API:
> FlatMapElements.into(TypeDescriptor).via(as usual).
> Likewise for MapElements. This allows getting rid of the awkward MissingOutputTypeDescriptor
intermediate class.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message