beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PostCommit_Python_Verify #1635
Date Mon, 27 Mar 2017 17:20:10 GMT
See <https://builds.apache.org/job/beam_PostCommit_Python_Verify/1635/display/redirect?page=changes>

Changes:

[dhalperi] [BEAM-1808] Fix typo isPastEndOfWindow => pastEndOfWindow

[dhalperi] Fix checkArgument error message args

[tgroh] Stop emailing individual committers in Performance tests

------------------------------------------
[...truncated 536.10 KB...]
test_getitem_duplicates_ignored (apache_beam.typehints.typehints_test.UnionHintTestCase) ...
ok
test_getitem_must_be_valid_type_param (apache_beam.typehints.typehints_test.UnionHintTestCase)
... ok
test_getitem_must_be_valid_type_param_cant_be_object_instance (apache_beam.typehints.typehints_test.UnionHintTestCase)
... ok
test_getitem_nested_unions_flattened (apache_beam.typehints.typehints_test.UnionHintTestCase)
... ok
test_nested_compatibility (apache_beam.typehints.typehints_test.UnionHintTestCase) ... ok
test_union_hint_compatibility (apache_beam.typehints.typehints_test.UnionHintTestCase) ...
ok
test_union_hint_enforcement_composite_type_in_union (apache_beam.typehints.typehints_test.UnionHintTestCase)
... ok
test_union_hint_enforcement_not_part_of_union (apache_beam.typehints.typehints_test.UnionHintTestCase)
... ok
test_union_hint_enforcement_part_of_union (apache_beam.typehints.typehints_test.UnionHintTestCase)
... ok
test_union_hint_repr (apache_beam.typehints.typehints_test.UnionHintTestCase) ... ok
test_deprecated_with_since_current (apache_beam.utils.annotations_test.AnnotationTests) ...
ok
test_deprecated_without_current (apache_beam.utils.annotations_test.AnnotationTests) ... ok
test_deprecated_without_since_should_fail (apache_beam.utils.annotations_test.AnnotationTests)
... ok
test_experimental_with_current (apache_beam.utils.annotations_test.AnnotationTests) ... ok
test_experimental_without_current (apache_beam.utils.annotations_test.AnnotationTests) ...
ok
test_frequency (apache_beam.utils.annotations_test.AnnotationTests)
Tests that the filter 'once' is sufficient to print once per ... ok
test_gcs_path (apache_beam.utils.path_test.Path) ... ok
test_unix_path (apache_beam.utils.path_test.Path) ... ok
test_windows_path (apache_beam.utils.path_test.Path) ... ok
test_dataflow_job_file (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_display_data (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_experiments (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_extra_package (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_from_dictionary (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_get_all_options (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_option_with_space (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_override_options (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_redefine_options (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_template_location (apache_beam.utils.pipeline_options_test.PipelineOptionsTest) ... ok
test_dataflow_job_file_and_template_location_mutually_exclusive (apache_beam.utils.pipeline_options_validator_test.SetupTest)
... ok
test_gcs_path (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_is_service_runner (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_job_name (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_local_runner (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_missing_required_options (apache_beam.utils.pipeline_options_validator_test.SetupTest)
... ok
test_num_workers (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_project (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_streaming (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_test_matcher (apache_beam.utils.pipeline_options_validator_test.SetupTest) ... ok
test_validate_dataflow_job_file (apache_beam.utils.pipeline_options_validator_test.SetupTest)
... ok
test_validate_template_location (apache_beam.utils.pipeline_options_validator_test.SetupTest)
... ok
test_method_forwarding_not_windows (apache_beam.utils.processes_test.Exec) ... ok
test_method_forwarding_windows (apache_beam.utils.processes_test.Exec) ... ok
test_call_two_objects (apache_beam.utils.retry_test.RetryStateTest) ... ok
test_single_failure (apache_beam.utils.retry_test.RetryStateTest) ... ok
test_two_failures (apache_beam.utils.retry_test.RetryStateTest) ... ok
test_log_calls_for_permanent_failure (apache_beam.utils.retry_test.RetryTest) ... ok
test_log_calls_for_transient_failure (apache_beam.utils.retry_test.RetryTest) ... ok
test_with_default_number_of_retries (apache_beam.utils.retry_test.RetryTest) ... ok
test_with_explicit_decorator (apache_beam.utils.retry_test.RetryTest) ... ok
test_with_explicit_initial_delay (apache_beam.utils.retry_test.RetryTest) ... ok
test_with_explicit_number_of_retries (apache_beam.utils.retry_test.RetryTest) ... ok
test_with_http_error_that_should_be_retried (apache_beam.utils.retry_test.RetryTest) ... SKIP:
google-apitools is not installed
test_with_http_error_that_should_not_be_retried (apache_beam.utils.retry_test.RetryTest) ...
SKIP: google-apitools is not installed
test_with_no_retry_decorator (apache_beam.utils.retry_test.RetryTest) ... ok
test_with_real_clock (apache_beam.utils.retry_test.RetryTest) ... ok
test_arithmetic (apache_beam.utils.timestamp_test.DurationTest) ... ok
test_of (apache_beam.utils.timestamp_test.DurationTest) ... ok
test_precision (apache_beam.utils.timestamp_test.DurationTest) ... ok
test_sort_order (apache_beam.utils.timestamp_test.DurationTest) ... ok
test_str (apache_beam.utils.timestamp_test.DurationTest) ... ok
test_arithmetic (apache_beam.utils.timestamp_test.TimestampTest) ... ok
test_of (apache_beam.utils.timestamp_test.TimestampTest) ... ok
test_precision (apache_beam.utils.timestamp_test.TimestampTest) ... ok
test_sort_order (apache_beam.utils.timestamp_test.TimestampTest) ... ok
test_str (apache_beam.utils.timestamp_test.TimestampTest) ... ok
test_utc_timestamp (apache_beam.utils.timestamp_test.TimestampTest) ... ok
test_equality (apache_beam.utils.windowed_value_test.WindowedValueTest) ... ok
test_hash (apache_beam.utils.windowed_value_test.WindowedValueTest) ... ok
test_pickle (apache_beam.utils.windowed_value_test.WindowedValueTest) ... ok
test_timestamps (apache_beam.utils.windowed_value_test.WindowedValueTest) ... ok
test_with_value (apache_beam.utils.windowed_value_test.WindowedValueTest) ... ok
test_context_param (apache_beam.pipeline_test.DoFnTest) ... ok
test_element (apache_beam.pipeline_test.DoFnTest) ... ok
test_side_input_no_tag (apache_beam.pipeline_test.DoFnTest) ... ok
test_side_input_tagged (apache_beam.pipeline_test.DoFnTest) ... ok
test_timestamp_param (apache_beam.pipeline_test.DoFnTest) ... ok
test_window_param (apache_beam.pipeline_test.DoFnTest) ... ok
test_attribute_setting (apache_beam.pipeline_test.PipelineOptionsTest) ... ok
test_defaults (apache_beam.pipeline_test.PipelineOptionsTest) ... ok
test_dir (apache_beam.pipeline_test.PipelineOptionsTest) ... ok
test_flag_parsing (apache_beam.pipeline_test.PipelineOptionsTest) ... ok
test_keyword_parsing (apache_beam.pipeline_test.PipelineOptionsTest) ... ok
test_view_as (apache_beam.pipeline_test.PipelineOptionsTest) ... ok
test_aggregator_empty_input (apache_beam.pipeline_test.PipelineTest) ... ok
test_apply_custom_transform (apache_beam.pipeline_test.PipelineTest) ... ok
test_create (apache_beam.pipeline_test.PipelineTest) ... ok
test_create_singleton_pcollection (apache_beam.pipeline_test.PipelineTest) ... ok
test_eager_pipeline (apache_beam.pipeline_test.PipelineTest) ... ok
test_flatmap_builtin (apache_beam.pipeline_test.PipelineTest) ... ok
test_memory_usage (apache_beam.pipeline_test.PipelineTest) ... ok
test_metrics_in_source (apache_beam.pipeline_test.PipelineTest) ... ok
test_pipeline_as_context (apache_beam.pipeline_test.PipelineTest) ... ok
test_read (apache_beam.pipeline_test.PipelineTest) ... ok
test_reuse_cloned_custom_transform_instance (apache_beam.pipeline_test.PipelineTest) ... ok
test_reuse_custom_transform_instance (apache_beam.pipeline_test.PipelineTest) ... <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/apache_beam/pipeline_test.py>:195:
DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  cm.exception.message,
ok
test_transform_no_super_init (apache_beam.pipeline_test.PipelineTest) ... ok
test_visit_entire_graph (apache_beam.pipeline_test.PipelineTest) ... ok
test_pcollectionview_not_recreated (apache_beam.pvalue_test.PValueTest) ... ok
test_pvalue_expected_arguments (apache_beam.pvalue_test.PValueTest) ... ok
test_append_extra_options (apache_beam.test_pipeline_test.TestPipelineTest) ... ok
test_append_verifier_in_extra_opt (apache_beam.test_pipeline_test.TestPipelineTest) ... ok
test_create_test_pipeline_options (apache_beam.test_pipeline_test.TestPipelineTest) ... ok
test_empty_option_args_parsing (apache_beam.test_pipeline_test.TestPipelineTest) ... ok
test_get_option (apache_beam.test_pipeline_test.TestPipelineTest) ... ok
test_option_args_parsing (apache_beam.test_pipeline_test.TestPipelineTest) ... ok
test_skip_IT (apache_beam.test_pipeline_test.TestPipelineTest) ... SKIP: IT is skipped because
--test-pipeline-options is not specified
test_file_checksum_matchcer_invalid_sleep_time (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
... <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/apache_beam/tests/pipeline_verifiers_test.py>:129:
DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  self.assertEqual(cm.exception.message,
ok
test_file_checksum_matcher_read_failed (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
... ok
test_file_checksum_matcher_service_error (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
... SKIP: google-apitools is not installed
test_file_checksum_matcher_sleep_before_verify (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
... ok
test_file_checksum_matcher_success (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
... ok
test_pipeline_state_matcher_fails (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
Test PipelineStateMatcher fails when using default expected state ... ok
test_pipeline_state_matcher_given_state (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
Test PipelineStateMatcher successes when matches given state ... ok
test_pipeline_state_matcher_success (apache_beam.tests.pipeline_verifiers_test.PipelineVerifiersTest)
Test PipelineStateMatcher successes when using default expected state ... ok

----------------------------------------------------------------------
Ran 1080 tests in 36.821s

OK (skipped=183)
py27cython runtests: commands[4] | - find apache_beam -type f -name *.c -delete
py27cython runtests: commands[5] | - find apache_beam -type f -name *.so -delete
py27cython runtests: commands[6] | - find target/build -type f -name *.c -delete
/usr/bin/find: `target/build': No such file or directory
py27cython runtests: commands[7] | - find target/build -type f -name *.so -delete
/usr/bin/find: `target/build': No such file or directory
py27gcp create: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp>
py27gcp installdeps: nose
py27gcp inst: <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/dist/apache-beam-0.7.0.dev.zip>
py27gcp installed: PyYAML==3.12,apache-beam==0.7.0.dev,argparse==1.2.1,avro==1.8.1,crcmod==1.7,dill==0.2.6,funcsigs==1.0.2,httplib2==0.9.2,mock==2.0.0,nose==1.3.7,oauth2client==3.0.0,pbr==2.0.0,protobuf==3.2.0,pyasn1==0.2.3,pyasn1-modules==0.0.8,rsa==3.4.2,six==1.10.0,wsgiref==0.1.2
py27gcp runtests: PYTHONHASHSEED='524480692'
py27gcp runtests: commands[0] | pip install -e .[test,gcp]
Obtaining file://<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python>
  Running setup.py (path:<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/setup.py)>
egg_info for package from file://<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python>
    <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/setup.py>:58:
UserWarning: You are using version 1.5.4 of pip. However, version 7.0.0 is recommended.
      _PIP_VERSION, REQUIRED_PIP_VERSION
    
  Installing extra requirements: 'test,gcp'
Requirement already satisfied (use --upgrade to upgrade): avro>=1.7.7,<2.0.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): crcmod>=1.7,<2.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): dill==0.2.6 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): httplib2>=0.8,<0.10 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): mock>=1.0.1,<3.0.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): oauth2client>=2.0.1,<4.0.0
in ./target/.tox/py27gcp/lib/python2.7/site-packages (from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): protobuf==3.2.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyyaml>=3.10,<4.0.0 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from apache-beam==0.7.0.dev)
Downloading/unpacking google-apitools>=0.5.6,<1.0.0 (from apache-beam==0.7.0.dev)
Downloading/unpacking proto-google-cloud-datastore-v1==0.90.0 (from apache-beam==0.7.0.dev)
  Downloading proto-google-cloud-datastore-v1-0.90.0.tar.gz
  Running setup.py (path:<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/build/proto-google-cloud-datastore-v1/setup.py)>
egg_info for package proto-google-cloud-datastore-v1
    
    warning: no previously-included files matching '*.py[co]' found anywhere in distribution
    warning: no previously-included files matching '__pycache__' found anywhere in distribution
Downloading/unpacking googledatastore==7.0.0 (from apache-beam==0.7.0.dev)
  Downloading googledatastore-7.0.0.tar.gz
  Running setup.py (path:<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/build/googledatastore/setup.py)>
egg_info for package googledatastore
    
Downloading/unpacking google-cloud-bigquery>=0.22.1,<0.23 (from apache-beam==0.7.0.dev)
Downloading/unpacking pyhamcrest>=1.9,<2.0 (from apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyasn1>=0.1.7 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): pyasn1-modules>=0.0.5 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): rsa>=3.1.4 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==0.7.0.dev)
Requirement already satisfied (use --upgrade to upgrade): six>=1.6.1 in ./target/.tox/py27gcp/lib/python2.7/site-packages
(from oauth2client>=2.0.1,<4.0.0->apache-beam==0.7.0.dev)
Downloading/unpacking setuptools>=18.5 (from google-apitools>=0.5.6,<1.0.0->apache-beam==0.7.0.dev)
Downloading/unpacking googleapis-common-protos>=1.5.0,<2.0dev (from proto-google-cloud-datastore-v1==0.90.0->apache-beam==0.7.0.dev)
  Downloading googleapis-common-protos-1.5.2.tar.gz
  Running setup.py (path:<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/build/googleapis-common-protos/setup.py)>
egg_info for package googleapis-common-protos
    
Downloading/unpacking google-cloud-core>=0.22.1,<0.23dev (from google-cloud-bigquery>=0.22.1,<0.23->apache-beam==0.7.0.dev)
Downloading/unpacking appdirs>=1.4.0 (from setuptools>=18.5->google-apitools>=0.5.6,<1.0.0->apache-beam==0.7.0.dev)
  Downloading appdirs-1.4.3-py2.py3-none-any.whl
Downloading/unpacking packaging>=16.8 (from setuptools>=18.5->google-apitools>=0.5.6,<1.0.0->apache-beam==0.7.0.dev)
  Downloading packaging-16.8-py2.py3-none-any.whl
Downloading/unpacking google-auth>=0.4.0,<2.0.0dev (from google-cloud-core>=0.22.1,<0.23dev->google-cloud-bigquery>=0.22.1,<0.23->apache-beam==0.7.0.dev)
Downloading/unpacking google-auth-httplib2 (from google-cloud-core>=0.22.1,<0.23dev->google-cloud-bigquery>=0.22.1,<0.23->apache-beam==0.7.0.dev)
  Downloading google_auth_httplib2-0.0.2-py2.py3-none-any.whl
Downloading/unpacking pyparsing (from packaging>=16.8->setuptools>=18.5->google-apitools>=0.5.6,<1.0.0->apache-beam==0.7.0.dev)
Installing collected packages: google-apitools, proto-google-cloud-datastore-v1, googledatastore,
google-cloud-bigquery, pyhamcrest, apache-beam, setuptools, googleapis-common-protos, google-cloud-core,
appdirs, packaging, google-auth, google-auth-httplib2, pyparsing
  Running setup.py install for proto-google-cloud-datastore-v1
    Skipping installation of <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/lib/python2.7/site-packages/google/__init__.py>
(namespace package)
    Skipping installation of <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/lib/python2.7/site-packages/google/cloud/__init__.py>
(namespace package)
    Skipping installation of <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/lib/python2.7/site-packages/google/cloud/proto/__init__.py>
(namespace package)
    Skipping installation of <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/lib/python2.7/site-packages/google/cloud/proto/datastore/__init__.py>
(namespace package)
    
    warning: no previously-included files matching '*.py[co]' found anywhere in distribution
    warning: no previously-included files matching '__pycache__' found anywhere in distribution
    Installing <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/lib/python2.7/site-packages/proto_google_cloud_datastore_v1-0.90.0-py2.7-nspkg.pth>
  Running setup.py install for googledatastore
    
  Running setup.py develop for apache-beam
    <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/setup.py>:58:
UserWarning: You are using version 1.5.4 of pip. However, version 7.0.0 is recommended.
      _PIP_VERSION, REQUIRED_PIP_VERSION
    
    Creating <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/lib/python2.7/site-packages/apache-beam.egg-link>
(link to .)
    Adding apache-beam 0.7.0.dev to easy-install.pth file
    
    Installed <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python>
  Found existing installation: setuptools 2.2
    Uninstalling setuptools:
      Successfully uninstalled setuptools
  Running setup.py install for googleapis-common-protos
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/setuptools/__init__.py",>
line 12, in <module>
        import setuptools.version
      File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/setuptools/version.py",>
line 1, in <module>
        import pkg_resources
      File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/pkg_resources/__init__.py",>
line 70, in <module>
        import packaging.version
    ImportError: No module named packaging.version
    Complete output from command <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/bin/python>
-c "import setuptools, tokenize;__file__='<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/build/googleapis-common-protos/setup.py';exec(compile(getattr(tokenize,>
'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record
/tmp/pip-Au8oV0-record/install-record.txt --single-version-externally-managed --compile --install-headers
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/include/site/python2.7>:
    Traceback (most recent call last):

  File "<string>", line 1, in <module>

  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/setuptools/__init__.py",>
line 12, in <module>

    import setuptools.version

  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/setuptools/version.py",>
line 1, in <module>

    import pkg_resources

  File "<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/local/lib/python2.7/site-packages/pkg_resources/__init__.py",>
line 70, in <module>

    import packaging.version

ImportError: No module named packaging.version

----------------------------------------
Cleaning up...
Command <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/bin/python>
-c "import setuptools, tokenize;__file__='<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/build/googleapis-common-protos/setup.py';exec(compile(getattr(tokenize,>
'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record
/tmp/pip-Au8oV0-record/install-record.txt --single-version-externally-managed --compile --install-headers
<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/include/site/python2.7>
failed with error code 1 in <https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/build/googleapis-common-protos>
Storing debug log for failure in /home/jenkins/.pip/pip.log
ERROR: InvocationError: '<https://builds.apache.org/job/beam_PostCommit_Python_Verify/ws/sdks/python/target/.tox/py27gcp/bin/pip>
install -e .[test,gcp]'
___________________________________ summary ____________________________________
ERROR:   docs: commands failed
  lint: commands succeeded
  py27: commands succeeded
  py27cython: commands succeeded
ERROR:   py27gcp: commands failed
Build step 'Execute shell' marked build as failure

Mime
View raw message