beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Halperin (JIRA)" <>
Subject [jira] [Commented] (BEAM-1107) Display user names for steps in the Flink Web UI
Date Wed, 07 Dec 2016 23:39:58 GMT


Daniel Halperin commented on BEAM-1107:

Ack -- I guess I have this intuition there's opportunity for more cleanup, but I may be wrong
(or it may be a Flink-general, not Beam-on-Flink issue).

E.g., look at the attached screenshot:

* The name (grey) at the top is MapPartition -> Map -> GroupCombine -> Map
* The name of the steps (black) includes the identical as the grey, with additionally (step
* The Operation: text (small, grey) at the bottom includes the same (almost - logical vs physical?)
information, although there appears to be some HTML error with inserting a break tag inside
another break tag.

> Display user names for steps in the Flink Web UI
> ------------------------------------------------
>                 Key: BEAM-1107
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: runner-flink
>            Reporter: Daniel Halperin
>            Assignee: Aljoscha Krettek
>         Attachments: screenshot-1.png
> [copying in-person / email discussion at Strata Singapore to JIRA]
> The FlinkBatchTransformTranslators use transform.getName() [1] -- this is the "SDK name"
for the transform.
> The "user name" for the transform is not available here, it is in fact on the TransformHierarchy.Node
as node.getFullName() [2].
> getFullName() is used some in Flink, but not when setting step names.
> I drafted a quick commit that sort of propagates the user names to the web UI (but only
for DataSource, and still too verbose:
> Before this change, the "ReadLines" step showed up as: "DataSource (at Read(CompressedSource)
> With this change, it shows up as "DataSource (at ReadLines/Read (org.apache.beam.runners.flink.translation.wrappers.SourceInputFormat))"
> which I think is closer. [I'd still like it to JUST be "ReadLines/Read" e.g.].
> Thoughts?
> [1]
> [2]

This message was sent by Atlassian JIRA

View raw message