beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Halperin (JIRA)" <>
Subject [jira] [Updated] (BEAM-655) Rename @RunnableOnService to something more descriptive
Date Thu, 01 Dec 2016 21:57:58 GMT


Daniel Halperin updated BEAM-655:
    Assignee: Mark Liu  (was: Jason Kuster)

> Rename @RunnableOnService to something more descriptive
> -------------------------------------------------------
>                 Key: BEAM-655
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: beam-model, sdk-java-core, sdk-py
>            Reporter: Jason Kuster
>            Assignee: Mark Liu
> There are currently two categories for unit tests in the Core Beam Java SDK: {{NeedsRunner}}
and {{RunnableOnService}}. These categories are insufficiently descriptive for describing
the tests that they categorize.
> There are two goals for these tests:
> * Demonstrate that a runner conforms with the Beam model and the Capability Matrix. These
capabilities are described at [Capability Matrix Testing|]
> * Demonstrate that a PTransform, when executed on a {{PipelineRunner}}, performs as specified
> NeedsRunner tests should either:
> * Be converted into a runner-independent test (for example, via use of DoFnTester to
test that a DoFn throws on invalid input)
> * Be converted into a RunnableOnService test
> RunnableOnService tests that explicitly test the capabilities of a Model primitive should
be categorized into that specific capability. Existing RunnableOnService tests that test the
execution of a PTransform should remain RunnableOnService.

This message was sent by Atlassian JIRA

View raw message