beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Chambers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-726) Standardize naming of PipelineResult objects
Date Thu, 06 Oct 2016 22:13:20 GMT

    [ https://issues.apache.org/jira/browse/BEAM-726?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15553367#comment-15553367
] 

Ben Chambers commented on BEAM-726:
-----------------------------------

Great point. We could consider also choosing a different suffix. Perhaps "PipelineExecution"
or "PipelineHandle" or something like that. That would need a little more discussion since
any user-code mentioning PipelineResult would then break. If we decide to rename it, it seems
like it would be good to do these together.

> Standardize naming of PipelineResult objects
> --------------------------------------------
>
>                 Key: BEAM-726
>                 URL: https://issues.apache.org/jira/browse/BEAM-726
>             Project: Beam
>          Issue Type: Bug
>          Components: beam-model
>            Reporter: Ben Chambers
>            Assignee: Frances Perry
>            Priority: Minor
>
> Today:
> PipelineResult is an interface returned by running a pipeline.
> DataflowPipelineJob is the Dataflow implementation of that interface
> FlinkRunnerResult is the Flink implementation
> EvaluationContext is the Spark implementation
> DirectPipelineResult is the DirectRunner implementation
> Ideally, all the names would indicate that they are a PipelineResult, like the DirectRunner
does.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message