beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Cwik (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-726) Standardize naming of PipelineResult objects
Date Thu, 06 Oct 2016 22:11:20 GMT

    [ https://issues.apache.org/jira/browse/BEAM-726?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15553364#comment-15553364
] 

Luke Cwik commented on BEAM-726:
--------------------------------

Is PipelineResult the appropriate suffix?
If I support a non-blocking mode then its not really a result yet which explains the choice
of the Job suffix for Dataflow.

> Standardize naming of PipelineResult objects
> --------------------------------------------
>
>                 Key: BEAM-726
>                 URL: https://issues.apache.org/jira/browse/BEAM-726
>             Project: Beam
>          Issue Type: Bug
>          Components: beam-model
>            Reporter: Ben Chambers
>            Assignee: Frances Perry
>            Priority: Minor
>
> Today:
> PipelineResult is an interface returned by running a pipeline.
> DataflowPipelineJob is the Dataflow implementation of that interface
> FlinkRunnerResult is the Flink implementation
> EvaluationContext is the Spark implementation
> DirectPipelineResult is the DirectRunner implementation
> Ideally, all the names would indicate that they are a PipelineResult, like the DirectRunner
does.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message