beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Bradshaw (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-239) Rename RemoveDuplicates to Distinct
Date Fri, 21 Oct 2016 04:07:58 GMT

    [ https://issues.apache.org/jira/browse/BEAM-239?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15593907#comment-15593907
] 

Robert Bradshaw commented on BEAM-239:
--------------------------------------

Pretty much all PTransforms are verbs. +1 to adding words like distinct and unique to the
documentation. 

> Rename RemoveDuplicates to Distinct
> -----------------------------------
>
>                 Key: BEAM-239
>                 URL: https://issues.apache.org/jira/browse/BEAM-239
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-java-core
>            Reporter: Jesse Anderson
>            Assignee: Neelesh Srinivas Salian
>            Priority: Minor
>              Labels: backward-incompatible, newbie, starter
>
> I had a really tough time finding this transform in the docs. I suggest changing this
class' name to Distinct instead of RemoveDuplicates. At the very least, the JavaDoc for RemoveDuplicates
should have the word distinct in it to make this more findable/searchable.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message