beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Wegner (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (BEAM-678) Python executable should be overridable
Date Thu, 29 Sep 2016 21:52:20 GMT

     [ https://issues.apache.org/jira/browse/BEAM-678?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Scott Wegner closed BEAM-678.
-----------------------------
       Resolution: Fixed
    Fix Version/s: Not applicable

> Python executable should be overridable
> ---------------------------------------
>
>                 Key: BEAM-678
>                 URL: https://issues.apache.org/jira/browse/BEAM-678
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-py
>            Reporter: Scott Wegner
>            Assignee: Scott Wegner
>            Priority: Minor
>             Fix For: Not applicable
>
>
> Since [PR 962|https://github.com/apache/incubator-beam/pull/962], dependency.py will
use {{sys.executable}} to source the python executable to use for managing dependencies. However,
as stated in the [python docs|https://docs.python.org/2/library/sys.html#sys.executable]:
> bq. If Python is unable to retrieve the real path to its executable, sys.executable will
be an empty string or None.
> To mitigate this, we should allow setting the python executable to use via an environment
variable.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message