beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Buccini (JIRA)" <>
Subject [jira] [Commented] (BEAM-517) Check versions of pip and cython
Date Mon, 26 Sep 2016 09:50:20 GMT


Marco Buccini commented on BEAM-517:

So, from my understanding we could specify the requirements for PIP in with the following:

import pkg_resources
assert str(pkg_resources.get_distribution('pip').version) >= '7.0.0', "This SDK requires
'pip' >= 7.0.0"

while mentioning it in the README file. 
(it seems that the --no-binary flag was introduced in version 7.0.0:

Regarding cython, I am not quite sure about the version needed to run the code, so probably
someone else might be able to tell more about it.

> Check versions of pip and cython
> --------------------------------
>                 Key: BEAM-517
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-py
>            Reporter: Ahmet Altay
>            Priority: Minor
>              Labels: starter
> Python SDK depends on pip and cython however it does not check the versions of these.
> Some of the pip flags does not exist in older versions:
> (Note: Even though the above issue was reported by the user in a different repo it is
related to the apache beam sdk)
> Similarly with cython, SDK supports running with or without Cython. Because of that reason
it is not list it as a requirement in the file. However, with an old version of cython
SDK might fail.
> To avoid the above problem: In the SDK check the version of these packages and show a
warning to upgrade.

This message was sent by Atlassian JIRA

View raw message