beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aljoscha Krettek (JIRA)" <>
Subject [jira] [Resolved] (BEAM-253) Unify Flink Operator Wrappers
Date Fri, 26 Aug 2016 05:49:21 GMT


Aljoscha Krettek resolved BEAM-253.
       Resolution: Fixed
    Fix Version/s: 0.3.0-incubating

Implemented here:

> Unify Flink Operator Wrappers
> -----------------------------
>                 Key: BEAM-253
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: runner-flink
>            Reporter: Aljoscha Krettek
>            Assignee: Aljoscha Krettek
>             Fix For: 0.3.0-incubating
> Right now, we have {{FlinkAbstractParDoWrapper}} with subclasses {{FlinkParDoBoundWrapper}}
and {{FlinkParDoBoundMultiWrapper}} as well as {{FlinkGroupAlsoByWindowWrapper}}. They do
essentially the same thing, but slightly differently. The first three are implemented as a
{{FlatMapFunction}} while the latter is implemented as a {{StreamOperator}} (which is more
low-level and gives access to state and timers and such).
> We should unify this into one wrapper. (With possibly a more concise name...)
> In the process of this we should also make sure that we always use a {{DoFnRunner}} via
{{DoFnRunners.createDefault}}. This will help reduce bugs such as [BEAM-241].

This message was sent by Atlassian JIRA

View raw message