beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BEAM-304) Build break: maven is picking up Kafka snapshots
Date Mon, 23 May 2016 20:24:14 GMT

    [ https://issues.apache.org/jira/browse/BEAM-304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15297015#comment-15297015
] 

ASF GitHub Bot commented on BEAM-304:
-------------------------------------

GitHub user dhalperi opened a pull request:

    https://github.com/apache/incubator-beam/pull/374

    [BEAM-304] KafkaIO: pin to current working version

    We have started picking up snapshot versions of the next version of Kafka, which cause
    build breaks. Pin to 0.9.0.1 which is the version we've been building with
    successfully.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/dhalperi/incubator-beam kafka-fixup

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/incubator-beam/pull/374.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #374
    
----
commit 8a67ca013d32eb9486b9c30ea0d2df68d096e419
Author: Dan Halperin <dhalperi@google.com>
Date:   2016-05-23T20:20:36Z

    KafkaIO: pin to current working version
    
    We have started picking up snapshot versions of the next version of Kafka, which cause
    build breaks. Pin to 0.9.0.1 which is the version we've been building with
    successfully.

----


> Build break: maven is picking up Kafka snapshots
> ------------------------------------------------
>
>                 Key: BEAM-304
>                 URL: https://issues.apache.org/jira/browse/BEAM-304
>             Project: Beam
>          Issue Type: Bug
>          Components: sdk-java-extensions
>            Reporter: Daniel Halperin
>            Assignee: Daniel Halperin
>            Priority: Critical
>
> A few concurrent issues:
> 1. We did not pick a specific version of Kafka in our pom, instead we just dependended
on 0.9+
> 2. It looks like Kafka has deployed a 0.10 snapshot
> 3. For some reason, our build is picking up snapshot versions instead of using only things
available on Maven central.
> 4. 0.10 version of KafkaIO has a breaking change that breaks our code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message