beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Chambers (JIRA)" <>
Subject [jira] [Commented] (BEAM-210) Be consistent with emitting final empty panes
Date Tue, 19 Apr 2016 20:16:25 GMT


Ben Chambers commented on BEAM-210:

Most important, I think, is to get rid of the implicit "if you have a watermark trigger, you
must want an ON_TIME pane even if it is empty".

I don't know if its "wins", so much as we produce an empty pane if either (the pane is ON_TIME
and we think you want an empty ON_TIME pane) OR (the pane is final and we know you want an
empty final pane).

+1 to a clarifying rename, although I don't think "incremental" and "replacement" actually
clarify that much. I would suggest that we standardize on a pane as "the elements since the
last triggering". When we output, we produce either the current pane (DISCARDING mode), or
all of the accumulated panes (ACCUMULATING mode). So calling these something like outputCurrentPane
and outputCumulativePanes (or outputAccumulatedPanes or something like that) may be clear?
This is orthogonal, and should probably move out of this issue and on to the dev list when
we want to perform said renaming.

> Be consistent with emitting final empty panes
> ---------------------------------------------
>                 Key: BEAM-210
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: runner-core
>            Reporter: Mark Shields
>            Assignee: Mark Shields
> Currently ReduceFnRunner.onTrigger uses shouldEmit to prevent empty final panes unless
the user has requested them.
> The same check needs to be done in ReduceFnRunner.onTimer

This message was sent by Atlassian JIRA

View raw message