beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davor Bonaci (JIRA)" <>
Subject [jira] [Commented] (BEAM-147) Rename Aggregator to [P]Metric
Date Fri, 25 Mar 2016 17:04:25 GMT


Davor Bonaci commented on BEAM-147:

I'd like to push back a little bit against this issue.

The problem with the Aggregator API is that it is unclear where we want to take this -- there
are many paths, and relatively little consensus. Once we finalize that, we should have a discussion
about the proper name. For now, we seem to be trying to find a descriptive name for something
that we don't yet know what it is or what it is going to be. This doesn't sound like the right
way to go; and/or we'll find ourselves in a situation where the name no longer describes the
concept well enough.

Robert, what do you think? I wouldn't touch this for the time being, let Aggregators evolve
in its own right.

> Rename Aggregator to [P]Metric
> ------------------------------
>                 Key: BEAM-147
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: beam-model, sdk-java-core, sdk-py
>            Reporter: Robert Bradshaw
>            Assignee: Frances Perry
> The name "Aggregator" is confusing.
> See discussion at
and . Exact
name still being bikeshedded.

This message was sent by Atlassian JIRA

View raw message