beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Halperin <dhalp...@google.com>
Subject Re: [jira] [Commented] (BEAM-147) Rename Aggregator to [P]Metric
Date Fri, 25 Mar 2016 17:32:07 GMT
I'm concerned that we will rename it, then the new semantics we choose will
result in a second rename. I agree with Davor that we should pin down the
interface and semantics so we only do the rename once.
On Fri, Mar 25, 2016 at 10:28 Robert Bradshaw (JIRA) <jira@apache.org>
wrote:

>
>     [
> https://issues.apache.org/jira/browse/BEAM-147?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15212123#comment-15212123
> ]
>
> Robert Bradshaw commented on BEAM-147:
> --------------------------------------
>
> There is consensus that the name "Aggregators" is confusing, and it makes
> sense to rename it as part of the larger set of backwards incompatible
> changes rather than later. Thought the exact semantics of this features is
> still being pounded out, it seems well enough defined to give it a name at
> this point.
>
> > Rename Aggregator to [P]Metric
> > ------------------------------
> >
> >                 Key: BEAM-147
> >                 URL: https://issues.apache.org/jira/browse/BEAM-147
> >             Project: Beam
> >          Issue Type: Bug
> >          Components: beam-model, sdk-java-core, sdk-py
> >            Reporter: Robert Bradshaw
> >            Assignee: Frances Perry
> >
> > The name "Aggregator" is confusing.
> > See discussion at
> http://mail-archives.apache.org/mod_mbox/incubator-beam-user/201603.mbox/browser
> and
> http://mail-archives.apache.org/mod_mbox/incubator-beam-dev/201603.mbox/browser
> . Exact name still being bikeshedded.
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v6.3.4#6332)
>

Mime
View raw message