beam-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PostCommit_Python_Chicago_Taxi_Flink #220
Date Thu, 27 Aug 2020 14:48:51 GMT
See <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/220/display/redirect?page=changes>

Changes:

[zyichi] Fix PairWithRestrictionFn process no attribute signature error

[leiyiz] implement query 12

[sychen] Refactor to reuse computation+key

[Kamil Wasilewski] [BEAM-10675] Clean up Python Load Tests

[Luke Cwik] [BEAM-10771] Fix whitespace error causing whitespace lint to fail

[noreply] [BEAM-4980] Upgrade to Netty 4.1.51.Final and Netty_tcnative

[noreply] [BEAM-10670] Make Twister2Runner opt-out for using an SDF powered Read

[saavan] Fix author names

[Boyuan Zhang] Handle split when truncate observes windows.

[noreply] [BEAM-10701] Add codecov config, fix paths hopefully (#12684)

[noreply] Merge pull request #12674 from [BEAM-8258] basic metric feature for

[noreply] Add skipped tests for Series.dt and Series.str methods (#12615)

[noreply] [BEAM-9547] Add a few more DataFrame operations (#12682)

[noreply] [BEAM-10821] Add Python SDK typing improvements to CHANGES.md (#12693)


------------------------------------------
[...truncated 135.83 KB...]
Collecting ipykernel
  Using cached ipykernel-4.10.1-py2-none-any.whl (109 kB)
Collecting qtconsole
  Using cached qtconsole-4.7.6-py2.py3-none-any.whl (118 kB)
Collecting ipywidgets
  Using cached ipywidgets-7.5.1-py2.py3-none-any.whl (121 kB)
Collecting jupyter-console
  Using cached jupyter_console-5.2.0-py2.py3-none-any.whl (20 kB)
Collecting nbconvert
  Using cached nbconvert-5.6.1-py2.py3-none-any.whl (455 kB)
Collecting nbformat
  Using cached nbformat-4.4.0-py2.py3-none-any.whl (155 kB)
Collecting jupyter-client>=5.2.0
  Using cached jupyter_client-5.3.5-py2.py3-none-any.whl (92 kB)
Processing /home/jenkins/.cache/pip/wheels/a2/d8/14/0457f16488d8cbc2cf18bccb5f1ceb59675787a80c649251bc/Send2Trash-1.5.0-py2-none-any.whl
Collecting ipaddress; python_version == "2.7"
  Using cached ipaddress-1.0.23-py2.py3-none-any.whl (18 kB)
Collecting jupyter-core>=4.4.0
  Using cached jupyter_core-4.6.3-py2.py3-none-any.whl (83 kB)
Collecting pyzmq>=17
  Using cached pyzmq-19.0.2-cp27-cp27mu-manylinux1_x86_64.whl (1.0 MB)
Collecting traitlets>=4.2.1
  Using cached traitlets-4.3.3-py2.py3-none-any.whl (75 kB)
Collecting jinja2
  Using cached Jinja2-2.11.2-py2.py3-none-any.whl (125 kB)
Processing /home/jenkins/.cache/pip/wheels/d8/83/af/e0dc6afbf3a2c51af8d6e3f9fbe790d0c581c2de05bc5d50f5/tornado-5.1.1-cp27-cp27mu-linux_x86_64.whl
Collecting terminado>=0.8.1
  Using cached terminado-0.8.3-py2.py3-none-any.whl (33 kB)
Collecting ipython-genutils
  Using cached ipython_genutils-0.2.0-py2.py3-none-any.whl (26 kB)
Collecting prometheus-client
  Using cached prometheus_client-0.8.0-py2.py3-none-any.whl (53 kB)
Requirement already satisfied: mock>=2.0.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (2.0.0)
Processing /home/jenkins/.cache/pip/wheels/48/54/87/2f4d1a48c87e43906477a3c93d9663c49ca092046d5a4b00b4/termcolor-1.1.0-py2-none-any.whl
Processing /home/jenkins/.cache/pip/wheels/d3/04/66/211e73f484c0d65c763e3f925b20d8b8a644d9e4132a1f1169/absl_py-0.10.0-py2-none-any.whl
Collecting backports.weakref>=1.0rc1
  Using cached backports.weakref-1.0.post1-py2.py3-none-any.whl (5.2 kB)
Requirement already satisfied: grpcio>=1.8.6 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (1.31.0)
Collecting tensorflow-estimator<1.15.0rc0,>=1.14.0rc0
  Using cached tensorflow_estimator-1.14.0-py2.py3-none-any.whl (488 kB)
Processing /home/jenkins/.cache/pip/wheels/71/a0/64/e2e0c93740e0460f4b7f036141b7c73b5e44ff38f690ddff9f/Keras_Applications-1.0.8-py2-none-any.whl
Processing /home/jenkins/.cache/pip/wheels/5b/d8/8e/81a83cb5321b940a954996f5b57fddc8976e712b3ac3a1a54b/wrapt-1.12.1-cp27-cp27mu-linux_x86_64.whl
Requirement already satisfied: numpy<2.0,>=1.14.5 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (1.16.6)
Collecting google-pasta>=0.1.6
  Using cached google_pasta-0.2.0-py2-none-any.whl (57 kB)
Requirement already satisfied: protobuf>=3.6.1 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (3.13.0)
Requirement already satisfied: six>=1.10.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (1.15.0)
Requirement already satisfied: wheel in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (0.35.1)
Collecting keras-preprocessing>=1.0.5
  Using cached Keras_Preprocessing-1.1.2-py2.py3-none-any.whl (42 kB)
Requirement already satisfied: enum34>=1.1.6 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow==1.14.0->-r requirements.txt (line 19)) (1.1.10)
Processing /home/jenkins/.cache/pip/wheels/cd/08/93/0689cf727b42a822b5293e4a8ad7a788a20bbad57f7b4c9d35/gast-0.4.0-py2-none-any.whl
Collecting astor>=0.6.0
  Using cached astor-0.8.1-py2.py3-none-any.whl (27 kB)
Collecting tensorboard<1.15.0,>=1.14.0
  Using cached tensorboard-1.14.0-py2-none-any.whl (3.1 MB)
Collecting scikit-learn<1,>=0.18
  Using cached scikit_learn-0.20.4-cp27-cp27mu-manylinux1_x86_64.whl (5.5 MB)
Requirement already satisfied: apache-beam[gcp]<3,>=2.11 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow-data-validation<0.14,>=0.13.1->-r requirements.txt (line 20)) (2.25.0.dev0)
Collecting joblib<1,>=0.12
  Using cached joblib-0.14.1-py2.py3-none-any.whl (294 kB)
Requirement already satisfied: pandas<1,>=0.18 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow-data-validation<0.14,>=0.13.1->-r requirements.txt (line 20)) (0.24.2)
Collecting IPython>=5.0
  Using cached ipython-5.10.0-py2-none-any.whl (760 kB)
Requirement already satisfied: googleapis-common-protos in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tensorflow-metadata<0.14,>=0.13.0->-r requirements.txt (line 21)) (1.52.0)
Collecting scipy==1.1.0
  Using cached scipy-1.1.0-cp27-cp27mu-manylinux1_x86_64.whl (30.8 MB)
Processing /home/jenkins/.cache/pip/wheels/6a/a5/14/25541ebcdeaf97a37b6d05c7ff15f5bd20f5e91b99d313e5b4/pydot-1.2.4-cp27-none-any.whl
Collecting qtpy
  Using cached QtPy-1.9.0-py2.py3-none-any.whl (54 kB)
Collecting pygments
  Using cached Pygments-2.5.2-py2.py3-none-any.whl (896 kB)
Collecting widgetsnbextension~=3.5.0
  Using cached widgetsnbextension-3.5.1-py2.py3-none-any.whl (2.2 MB)
Collecting prompt-toolkit<2.0.0,>=1.0.0
  Using cached prompt_toolkit-1.0.18-py2-none-any.whl (245 kB)
Collecting mistune<2,>=0.8.1
  Using cached mistune-0.8.4-py2.py3-none-any.whl (16 kB)
Collecting defusedxml
  Using cached defusedxml-0.6.0-py2.py3-none-any.whl (23 kB)
Collecting entrypoints>=0.2.2
  Using cached entrypoints-0.3-py2.py3-none-any.whl (11 kB)
Collecting bleach
  Using cached bleach-3.1.5-py2.py3-none-any.whl (151 kB)
Processing /home/jenkins/.cache/pip/wheels/49/82/c2/20339405e38b5650a69542cbbcb85082f6840c488ecd22d02e/pandocfilters-1.4.2-py2-none-any.whl
Collecting testpath
  Using cached testpath-0.4.4-py2.py3-none-any.whl (163 kB)
Collecting jsonschema!=2.5.0,>=2.4
  Using cached jsonschema-3.2.0-py2.py3-none-any.whl (56 kB)
Requirement already satisfied: python-dateutil>=2.1 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from jupyter-client>=5.2.0->notebook<5.8,>=5.7.8->-r requirements.txt (line
18)) (2.8.1)
Collecting decorator
  Using cached decorator-4.4.2-py2.py3-none-any.whl (9.2 kB)
Collecting MarkupSafe>=0.23
  Using cached MarkupSafe-1.1.1-cp27-cp27mu-manylinux1_x86_64.whl (24 kB)
Collecting backports-abc>=0.4
  Using cached backports_abc-0.5-py2.py3-none-any.whl (5.2 kB)
Requirement already satisfied: singledispatch in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tornado<7,>=4.1->notebook<5.8,>=5.7.8->-r requirements.txt (line 18))
(3.4.0.3)
Requirement already satisfied: futures in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from tornado<7,>=4.1->notebook<5.8,>=5.7.8->-r requirements.txt (line 18))
(3.3.0)
Collecting ptyprocess; os_name != "nt"
  Using cached ptyprocess-0.6.0-py2.py3-none-any.whl (39 kB)
Requirement already satisfied: pbr>=0.11 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from mock>=2.0.0->tensorflow==1.14.0->-r requirements.txt (line 19)) (5.4.5)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from mock>=2.0.0->tensorflow==1.14.0->-r requirements.txt (line 19)) (1.0.2)
Collecting h5py
  Using cached h5py-2.10.0-cp27-cp27mu-manylinux1_x86_64.whl (2.8 MB)
Requirement already satisfied: setuptools in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from protobuf>=3.6.1->tensorflow==1.14.0->-r requirements.txt (line 19)) (44.1.1)
Collecting markdown>=2.6.8
  Using cached Markdown-3.1.1-py2.py3-none-any.whl (87 kB)
Collecting werkzeug>=0.11.15
  Using cached Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Requirement already satisfied: avro<1.10.0,>=1.8.1; python_version < "3.0" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.9.2)
Requirement already satisfied: crcmod<2.0,>=1.7 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.7)
Requirement already satisfied: oauth2client<4,>=2.0.1 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (3.0.0)
Requirement already satisfied: typing-extensions<3.8.0,>=3.7.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (3.7.4.3)
Requirement already satisfied: future<1.0.0,>=0.18.2 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.18.2)
Requirement already satisfied: pymongo<4.0.0,>=3.8.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (3.11.0)
Requirement already satisfied: pyarrow<0.18.0,>=0.15.1; python_version >= "3.0" or
platform_system != "Windows" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.16.0)
Requirement already satisfied: requests<3.0.0,>=2.24.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (2.24.0)
Requirement already satisfied: pyvcf<0.7.0,>=0.6.8; python_version < "3.0" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.6.8)
Requirement already satisfied: typing<3.8.0,>=3.7.0; python_full_version < "3.5.3"
in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (3.7.4.3)
Requirement already satisfied: pytz>=2018.3 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (2020.1)
Requirement already satisfied: httplib2<0.18.0,>=0.8 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.17.4)
Requirement already satisfied: hdfs<3.0.0,>=2.1.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (2.5.8)
Requirement already satisfied: dill<0.3.2,>=0.3.1.1 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.3.1.1)
Requirement already satisfied: fastavro<0.24,>=0.21.4 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.23.6)
Requirement already satisfied: google-cloud-spanner<2,>=1.13.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.18.0)
Requirement already satisfied: google-apitools<0.5.32,>=0.5.31; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.5.31)
Requirement already satisfied: google-cloud-core<2,>=0.28.1; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.4.1)
Requirement already satisfied: google-cloud-bigtable<2,>=0.31.1; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.4.0)
Requirement already satisfied: grpcio-gcp<1,>=0.2.2; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.2.2)
Requirement already satisfied: google-cloud-vision<2,>=0.38.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.0.0)
Requirement already satisfied: google-cloud-language<2,>=1.3.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.3.0)
Requirement already satisfied: google-cloud-videointelligence<2,>=1.8.0; extra == "gcp"
in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.15.0)
Requirement already satisfied: google-cloud-dlp<2,>=0.12.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.0.0)
Requirement already satisfied: google-cloud-pubsub<2,>=0.39.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.7.0)
Requirement already satisfied: google-cloud-bigquery<2,>=1.6.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.27.2)
Requirement already satisfied: google-auth<2,>=1.18.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.20.1)
Requirement already satisfied: cachetools<4,>=3.1.0; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (3.1.1)
Requirement already satisfied: google-cloud-datastore<2,>=1.7.1; extra == "gcp" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.15.0)
Collecting backports.shutil-get-terminal-size; python_version == "2.7"
  Using cached backports.shutil_get_terminal_size-1.0.0-py2.py3-none-any.whl (6.5 kB)
Requirement already satisfied: pathlib2; python_version == "2.7" or python_version == "3.3"
in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from IPython>=5.0->tensorflow-data-validation<0.14,>=0.13.1->-r requirements.txt
(line 20)) (2.3.5)
Collecting pexpect; sys_platform != "win32"
  Using cached pexpect-4.8.0-py2.py3-none-any.whl (59 kB)
Processing /home/jenkins/.cache/pip/wheels/1b/83/23/9d866729c0090bfc62d03a5bd43080fb07a5f4fad10a09399a/simplegeneric-0.8.1-py2-none-any.whl
Collecting pickleshare
  Using cached pickleshare-0.7.5-py2.py3-none-any.whl (6.9 kB)
Requirement already satisfied: pyparsing>=2.1.4 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from pydot<1.3,>=1.2.0->tensorflow-transform<0.14,>=0.13.0->-r requirements.txt
(line 24)) (2.4.7)
Requirement already satisfied: wcwidth in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from prompt-toolkit<2.0.0,>=1.0.0->jupyter-console->jupyter<2,>=1.0->-r
requirements.txt (line 17)) (0.2.5)
Requirement already satisfied: configparser>=3.5; python_version == "2.7" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from entrypoints>=0.2.2->nbconvert->jupyter<2,>=1.0->-r requirements.txt
(line 17)) (4.0.2)
Collecting webencodings
  Using cached webencodings-0.5.1-py2.py3-none-any.whl (11 kB)
Requirement already satisfied: packaging in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from bleach->nbconvert->jupyter<2,>=1.0->-r requirements.txt (line 17)) (20.4)
Processing /home/jenkins/.cache/pip/wheels/c2/ea/a3/25af52265fad6418a74df0b8d9ca8b89e0b3735dbd4d0d3794/functools32-3.2.3.post2-py2-none-any.whl
Processing /home/jenkins/.cache/pip/wheels/1f/d0/6d/4eb101c505cdc5e2be006684c0b93f3095a8ac5e0cf9abb35c/pyrsistent-0.16.0-cp27-cp27mu-linux_x86_64.whl
Requirement already satisfied: attrs>=17.4.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from jsonschema!=2.5.0,>=2.4->nbformat->notebook<5.8,>=5.7.8->-r requirements.txt
(line 18)) (20.1.0)
Requirement already satisfied: importlib-metadata; python_version < "3.8" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from jsonschema!=2.5.0,>=2.4->nbformat->notebook<5.8,>=5.7.8->-r requirements.txt
(line 18)) (1.7.0)
Requirement already satisfied: rsa>=3.1.4 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from oauth2client<4,>=2.0.1->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (4.0)
Requirement already satisfied: pyasn1>=0.1.7 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from oauth2client<4,>=2.0.1->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.4.8)
Requirement already satisfied: pyasn1-modules>=0.0.5 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from oauth2client<4,>=2.0.1->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.2.8)
Requirement already satisfied: certifi>=2017.4.17 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from requests<3.0.0,>=2.24.0->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (2020.6.20)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from requests<3.0.0,>=2.24.0->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.25.10)
Requirement already satisfied: idna<3,>=2.5 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from requests<3.0.0,>=2.24.0->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (2.10)
Requirement already satisfied: chardet<4,>=3.0.2 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from requests<3.0.0,>=2.24.0->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (3.0.4)
Requirement already satisfied: docopt in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from hdfs<3.0.0,>=2.1.0->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.6.2)
Requirement already satisfied: google-api-core[grpc,grpcgcp]<2.0.0dev,>=1.14.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from google-cloud-spanner<2,>=1.13.0; extra == "gcp"->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.22.1)
Requirement already satisfied: grpc-google-iam-v1<0.13dev,>=0.12.3 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from google-cloud-spanner<2,>=1.13.0; extra == "gcp"->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.12.3)
Requirement already satisfied: fasteners>=0.14 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from google-apitools<0.5.32,>=0.5.31; extra == "gcp"->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (0.15)
Requirement already satisfied: google-resumable-media<2.0dev,>=0.5.0 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from google-cloud-bigquery<2,>=1.6.0; extra == "gcp"->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.0.0)
Requirement already satisfied: scandir; python_version < "3.5" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from pathlib2; python_version == "2.7" or python_version == "3.3"->IPython>=5.0->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.10.0)
Requirement already satisfied: backports.functools-lru-cache>=1.2.1; python_version <
"3.2" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from wcwidth->prompt-toolkit<2.0.0,>=1.0.0->jupyter-console->jupyter<2,>=1.0->-r
requirements.txt (line 17)) (1.6.1)
Requirement already satisfied: contextlib2; python_version < "3" in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from importlib-metadata; python_version < "3.8"->jsonschema!=2.5.0,>=2.4->nbformat->notebook<5.8,>=5.7.8->-r
requirements.txt (line 18)) (0.6.0.post1)
Requirement already satisfied: zipp>=0.5 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from importlib-metadata; python_version < "3.8"->jsonschema!=2.5.0,>=2.4->nbformat->notebook<5.8,>=5.7.8->-r
requirements.txt (line 18)) (1.2.0)
Requirement already satisfied: monotonic>=0.1 in <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/lib/python2.7/site-packages>
(from fasteners>=0.14->google-apitools<0.5.32,>=0.5.31; extra == "gcp"->apache-beam[gcp]<3,>=2.11->tensorflow-data-validation<0.14,>=0.13.1->-r
requirements.txt (line 20)) (1.5)
Installing collected packages: decorator, ipython-genutils, traitlets, jupyter-core, backports-abc,
tornado, pyzmq, jupyter-client, backports.shutil-get-terminal-size, prompt-toolkit, ptyprocess,
pexpect, pygments, simplegeneric, pickleshare, IPython, ipykernel, qtpy, qtconsole, functools32,
pyrsistent, jsonschema, nbformat, Send2Trash, ipaddress, MarkupSafe, jinja2, mistune, defusedxml,
entrypoints, webencodings, bleach, pandocfilters, testpath, nbconvert, terminado, prometheus-client,
notebook, widgetsnbextension, ipywidgets, jupyter-console, jupyter, termcolor, absl-py, backports.weakref,
tensorflow-estimator, h5py, keras-applications, wrapt, google-pasta, keras-preprocessing,
gast, astor, markdown, werkzeug, tensorboard, tensorflow, scipy, scikit-learn, tensorflow-metadata,
joblib, pydot, tensorflow-transform, tensorflow-data-validation, tensorflow-model-analysis,
tensorflow-serving-api
  Attempting uninstall: pydot
    Found existing installation: pydot 1.4.1
    Uninstalling pydot-1.4.1:
      Successfully uninstalled pydot-1.4.1
Successfully installed IPython-5.10.0 MarkupSafe-1.1.1 Send2Trash-1.5.0 absl-py-0.10.0 astor-0.8.1
backports-abc-0.5 backports.shutil-get-terminal-size-1.0.0 backports.weakref-1.0.post1 bleach-3.1.5
decorator-4.4.2 defusedxml-0.6.0 entrypoints-0.3 functools32-3.2.3.post2 gast-0.4.0 google-pasta-0.2.0
h5py-2.10.0 ipaddress-1.0.23 ipykernel-4.10.1 ipython-genutils-0.2.0 ipywidgets-7.5.1 jinja2-2.11.2
joblib-0.14.1 jsonschema-3.2.0 jupyter-1.0.0 jupyter-client-5.3.5 jupyter-console-5.2.0 jupyter-core-4.6.3
keras-applications-1.0.8 keras-preprocessing-1.1.2 markdown-3.1.1 mistune-0.8.4 nbconvert-5.6.1
nbformat-4.4.0 notebook-5.7.10 pandocfilters-1.4.2 pexpect-4.8.0 pickleshare-0.7.5 prometheus-client-0.8.0
prompt-toolkit-1.0.18 ptyprocess-0.6.0 pydot-1.2.4 pygments-2.5.2 pyrsistent-0.16.0 pyzmq-19.0.2
qtconsole-4.7.6 qtpy-1.9.0 scikit-learn-0.20.4 scipy-1.1.0 simplegeneric-0.8.1 tensorboard-1.14.0
tensorflow-1.14.0 tensorflow-data-validation-0.13.1 tensorflow-estimator-1.14.0 tensorflow-metadata-0.13.0
tensorflow-model-analysis-0.13.2 tensorflow-serving-api-1.13.1 tensorflow-transform-0.13.0
termcolor-1.1.0 terminado-0.8.3 testpath-0.4.4 tornado-5.1.1 traitlets-4.3.3 webencodings-0.5.1
werkzeug-1.0.1 widgetsnbextension-3.5.1 wrapt-1.12.1

> Task :sdks:python:test-suites:portable:py2:chicagoTaxiExample
Using GCP project: apache-beam-testing
Job output path: gs://temp-storage-for-perf-tests/chicago-taxi/chicago-taxi-tfdv-20200827-144046/chicago_taxi_output
TFDV output path: gs://temp-storage-for-perf-tests/chicago-taxi/chicago-taxi-tfdv-20200827-144046/chicago_taxi_output/tfdv_output
Starting distributed TFDV stats computation and schema generation...
<https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/apache_beam/__init__.py>:82:
UserWarning: You are using the final Apache Beam release with Python 2 support. New releases
of Apache Beam will require Python 3.6 or a newer version.
  'You are using the final Apache Beam release with Python 2 support. '
<https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/apache_beam/io/gcp/bigquery.py>:1875:
BeamDeprecationWarning: options is deprecated since First stable release. References to <pipeline>.options
will not be supported
  temp_location = pcoll.pipeline.options.view_as(
WARNING:tensorflow:From <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/tensorflow_transform/analyzers.py>:948:
The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

WARNING:tensorflow:From <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/tensorflow_transform/analyzers.py>:948:
The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

2020-08-27 14:40:52.012102: I tensorflow/core/platform/cpu_feature_guard.cc:142] Your CPU
supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA
2020-08-27 14:40:52.022267: I tensorflow/core/platform/profile_utils/cpu_utils.cc:94] CPU
Frequency: 2300000000 Hz
2020-08-27 14:40:52.023385: I tensorflow/compiler/xla/service/service.cc:168] XLA service
0x8b7d4f0 executing computations on platform Host. Devices:
2020-08-27 14:40:52.023428: I tensorflow/compiler/xla/service/service.cc:175]   StreamExecutor
device (0): <undefined>, <undefined>
2020-08-27 14:40:52.036751: W tensorflow/compiler/jit/mark_for_compilation_pass.cc:1412] (One-time
warning): Not using XLA:CPU for cluster because envvar TF_XLA_FLAGS=--tf_xla_cpu_global_jit
was not set.  If you want XLA:CPU, either set that envvar, or use experimental_jit_scope to
enable XLA:CPU.  To confirm that XLA is active, pass --vmodule=xla_compilation_cache=1 (as
a proper command-line flag, not via TF_XLA_FLAGS) or set the envvar XLA_FLAGS=--xla_hlo_profile.
WARNING:tensorflow:From <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/tensorflow_transform/analyzers.py>:994:
The name tf.placeholder is deprecated. Please use tf.compat.v1.placeholder instead.

WARNING:tensorflow:From <https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/tensorflow_transform/analyzers.py>:994:
The name tf.placeholder is deprecated. Please use tf.compat.v1.placeholder instead.

warning: sdist: standard file not found: should have one of README, README.rst, README.txt,
README.md

warning: check: missing required meta-data: url

warning: check: missing meta-data: either (author and author_email) or (maintainer and maintainer_email)
must be supplied

WARNING:root:Make sure that locally built Python SDK docker image has Python 2.7 interpreter.
ERROR:root:java.util.concurrent.TimeoutException
Traceback (most recent call last):
  File "tfdv_analyze_and_validate.py", line 228, in <module>
    main()
  File "tfdv_analyze_and_validate.py", line 213, in main
    project=known_args.metric_reporting_project)
  File "tfdv_analyze_and_validate.py", line 133, in compute_stats
    result.wait_until_finish()
  File "<https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/build/gradleenv/1866363813/local/lib/python2.7/site-packages/apache_beam/runners/portability/portable_runner.py",>
line 550, in wait_until_finish
    raise self._runtime_exception
RuntimeError: Pipeline chicago-taxi-tfdv-20200827-144046_53be163f-849b-4294-a3c4-bd313626be1e
failed in state FAILED: java.util.concurrent.TimeoutException

> Task :sdks:python:test-suites:portable:py2:chicagoTaxiExample FAILED

FAILURE: Build failed with an exception.

* Where:
Build file '<https://ci-beam.apache.org/job/beam_PostCommit_Python_Chicago_Taxi_Flink/ws/src/sdks/python/test-suites/portable/py2/build.gradle'>
line: 125

* What went wrong:
Execution failed for task ':sdks:python:test-suites:portable:py2:chicagoTaxiExample'.
> Process 'command 'sh'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to
get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.2.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 9m 27s
6 actionable tasks: 5 executed, 1 up-to-date

Publishing build scan...
https://gradle.com/s/w3pq36q6aipwi

Build step 'Invoke Gradle script' changed build result to FAILURE
Build step 'Invoke Gradle script' marked build as failure


---------------------------------------------------------------------
To unsubscribe, e-mail: builds-unsubscribe@beam.apache.org
For additional commands, e-mail: builds-help@beam.apache.org


Mime
View raw message